EleksROM V3.6 丨 Full AutoMactic Upgrade And Set Param SoftWare - Download && Instruction


  • ElekMaker Develop Department

    New Version is Coming Now

    EleksROM V3.7 丨 Brand New CoreXY/XY 丨 Laser/Servo Mode Easy Switch Firmware Release

    Hi , Thx For Purchase Our Products

    From 3 month ago , we start to upgrade our EleksLaser Desktop Engraving Machine and use brand-new Mana SE Controller.

    Cause we have various Desktop Engraving or Draw Machine , So when you get our product with Mana SE Controller ,

    you need to Set Paramto Mana SE Controller.
     

    And Now We Have Full AutoMactic Upgrade And Set Param SoftWare Called EleksROM For You.

    Please Attention - The Following Controller  Support This SoftWare
    
    
    Supported Controller:
    
    EleksMaker Mana SE Controller  (V1.3/V2.1 Default Is V2.1 With No Version String On It)
    
    EleksMaker Mana Controller  (V2.1)
    
    EleksMaker L7 Controller  (For this Controller Model , you need follow this instruction to Upgrade)
    

      EleksMaker L7 Controller Upgrade Instruction Here

    Please Attention - The Following HardWare  Support This SoftWare 
    Supported Machine:
    
    EleksLaser A3  (Laser Power : 500mw/1600mw/2500mw/5500mw/7000mw)
    
    EleksLaser A5  (Laser Power : 500mw/1600mw/2500mw/5500mw/7000mw)
    
    EleksDraw  (With Draw module or Laser Power : None/500mw/1600mw/2500mw/5500mw/7000mw)
    
    EleksDrawPro  (With Draw module or Laser Power : None/500mw/1600mw/2500mw/5500mw/7000mw)
    
    EleksMill  (With Moter module or Laser Power : None/500mw)
    
    EleksEgg  (With Draw module)
    

     
     

    First Step:

      Click Here To Download EleksROM V3.6

    When Download is accomplished , Click EleksROM.zip To UnZip it.

    0_1487739348357_QQ截图20170222125032.jpg

    Then you can click on EleksROM.exe to directly Run or right click on EleksROM.exe to make a Shotcut to desktop

    0_1487739602308_QQ截图20170222125106.jpg

    Please Attention : Please Inset Your EleksMaker Controller First Before Open The EleksROM
    

     
     

    Step2:

    When EleksROM Initialization Complete . Just Choose Which EleksMaker Machine You Are Using And Click On That one IMG (EleksDraw && EleksDrawPro using the same option And you dont needed to choose which Controller you are using )

    0_1487739802514_QQ截图20170222110628.jpg

     
     

    Step3:

    Then You Can Choose The SerialPort Which Your Machine Is Using And Clik Connect SerialPort.

    0_1487740194851_QQ截图20170222110645.jpg
     
     

    Step 4:

    Then You Just Need Click To DownLoad Button To Automaticlly Download and set param for your Controller.

    0_1487740311312_QQ截图20170222110657.jpg

     
     
     
     
     

    From Now , You Dont Need To Click Anything And Just Wait a Few Minute.

    0_1487740947257_QQ截图20170222110706.jpg

    Do Not UnPlug Your Controller Out At This Time , It May Broke Your Controller.
    

     
     

    0_1487741104602_QQ截图20170222110728.jpg

    FirmWare Downloading is accomplish at this time.
    

     
     

    1_1487741104602_QQ截图20170222110735.jpg

    Please Wait About 30s. While Controller Is Rebooting.
    

     
     

    0_1487741305189_QQ截图20170222110741.jpg

    Now Controller Is Set Param Automaticlly.
    

     
     

    1_1487741305189_QQ截图20170222110745.jpg
     

    All DownLoad Completed , Just Plug Out Your Machine And SoftWare Will Closed Automaticlly. Thanks For Choosing Our Products.

     
     


  • EleksMaker Customer Service

    Any question about EleksROM software can reply in this page , we will answer for you.



  • @EleksMaker-Z

    I ordered a month ago 3 laser printers 2.5W, do I need to change the rom?


  • ElekMaker Develop Department

    Hi,
    You dont need change rom if your products is EleksLaser

    This is only for EleksDraw 、EleksEGG and EleksMill Series

    Thx for choosing our products

    Best Regards,
    EleksMake Z



  • @EleksMaker-Z
    EleksMill also bought but without the laser, or have a rom to exchange?


  • ElekMaker Develop Department

    @darek
    this software can help you to restore the broken firmware and settings , when you are using EleksLaser and EleksMii , you can use this to restore the settings , but is not a must be complete job.

    if you are using EleksDraw and EleksEgg , please use this software before starting any carve works, cause this two machine use different firmware and settings.



  • Hi!!I have a elekslaser 2.5W with Mana SE. I can't engrave with EleksCAM. What's the firmware that i need to use?Can you post me a link?


  • Developer of T2Laser Software

    It is included in their zip, it's called Mana.hex which I think is Grbl 0.9g but perhaps they modified it. The latest Grbl 1.1 has smoother motion and advanced features but I don't know if they support it.

    http://oss.eleksmaker.com/software/EleksROM.zip



  • @EleksMaker-Z i do everything that you say, and don´t work.

    The upgrade ok. but the error.... continue
    Upgrade: https://www.youtube.com/watch?v=W2w2YIvmk_A
    The error with more details: https://www.youtube.com/watch?v=reTBZpLO3QA



  • @ElekMaker-Develop-Department @EleksMaker-Z @EleksMaker-Customer-Service , please, someone help me :-(
    I will stop to buy this equipment if don´t work with EleksCAM, i buy this machine to sell in my country. Please help-me.
    I have another video of problem, now i test loading an .nc file, the motors work

    But continue don't work if i load image from picCave :-(



  • I have an Eleksegg and when trying to perform the FW upgrade I get the following error, it appears just after clicking on the upload FW bar, it appears to write the FW properly but the servo acts weird:

    0_1490066785008_EleksROM Error.JPG



  • Download libusb0.dll from the internet and copy it to your PC c: / windows / systen32
    Then everything will be ok



  • @raadel
    Thank you, I actually found it in the firmware directory of the EleksCAM software and I copied it from there, then it worked fine.



  • @alpard78 Great, now to enjoy



  • @EleksMaker-Z how can install the firmware your software is incomplete plz update this and send me the link how can install the usb driver and firmware



  • Your software does not work......
    After a 3 hour search I was finally able to add the libusb0.dll which seems to be missing from every windows 10 machine in my possession. Why not just include the damn thing with your software. Once installed the Eleksrom v3.8 crashes on the two different machines I tried it on. providing the following error.alt text
    https://goo.gl/photos/moVYVDGykN7VN6pq9
    When using eleksCAM the outline function produces no result with any files. I have tried this on 2 different computers.


  • EleksMaker CEO

    @smartin If you see:0xc00007b means you miss DirectX



  • @EleksMaker
    Installing Directx does not correct the problem. Google says this is a .net framework problem, but there is no mechanism in Windows 10 to uninstall and reinstall that software. Please try again and provide a fix for your CAM problem as well.



  • When I try to run EleksRom I get "eleksrom.exe is not a valid Win32 application". Any ideas?



  • I loaded the new Egg firmware and the servo quits going crazy but now it won't lift the pen no matter what I do. I've tried re-attaching the arm at different places but that didn't help. I've tried a adjusting the laser power but that doesn't help. Any ideas?


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.