unable to download



  • I tried to install the app. I get an error. I cannot find the file it calls for.

    An error occurred trying to download 'https://t2laser.blob.core.windows.net/install/T2Laser.application'.

    See the setup log file located at 'C:\Users[name]\AppData\Local\Temp\VSD2EC9.tmp\install.log' for more information.



  • Found the log:

    The following properties have been set:
    Property: [AdminUser] = true {boolean}
    Property: [InstallMode] = HomeSite {string}
    Property: [NTProductType] = 1 {int}
    Property: [ProcessorArchitecture] = AMD64 {string}
    Property: [VersionNT] = 6.1.1 {version}
    Running checks for package 'Microsoft .NET Framework 4.5 (x86 and x64)', phase BuildList
    Reading value 'Version' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v4\Full'
    Read string value '4.5.51209'
    Setting value '4.5.51209 {string}' for property 'DotNet45Full_TargetVersion'
    The following properties have been set for package 'Microsoft .NET Framework 4.5 (x86 and x64)':
    Property: [DotNet45Full_TargetVersion] = 4.5.51209 {string}
    Running checks for command 'DotNetFX45\dotNetFx45_Full_x86_x64.exe'
    Result of running operator 'ValueEqualTo' on property 'InstallMode' and value 'HomeSite': true
    Result of checks for command 'DotNetFX45\dotNetFx45_Full_x86_x64.exe' is 'Bypass'
    Running checks for command 'DotNetFX45\dotNetFx45_Full_setup.exe'
    Result of running operator 'ValueNotEqualTo' on property 'InstallMode' and value 'HomeSite': false
    Result of running operator 'VersionGreaterThanOrEqualTo' on property 'DotNet45Full_TargetVersion' and value '4.5.50709': true
    Result of checks for command 'DotNetFX45\dotNetFx45_Full_setup.exe' is 'Bypass'
    'Microsoft .NET Framework 4.5 (x86 and x64)' RunCheck result: No Install Needed
    Launching Application.
    URLDownloadToCacheFile failed with HRESULT '-2146697208'
    Error: An error occurred trying to download 'https://t2laser.blob.core.windows.net/install/T2Laser.application'.


  • Developer of T2Laser Software

    @timofthedeep It appears to be failing to load .net, the Microsoft ClickOnce installer gets prerequisites from their server.



  • @Zax I checked in control panel, and dotnet 4.5.2 is installed. I even went to the repair option and set it back to initial install. The dotnet wizard says everything is ok with it. I am admin on this system, so that isn't it either. Weird.


  • Developer of T2Laser Software

    @timofthedeep You can try clearing the ClickOnce cache in case it got corrupted. That's where T2Laser is installed by Microsoft's installer.

    Go to C:\Users[username]\AppData\Local\Apps\2.0 and delete the sub folders but leave the 2.0 folder (change [username] to your user name).



  • @Zax Cleared cache. No change. No download. Do you have an offline download available?



  • @Zax installed dotnet4.7.x No change.


  • Developer of T2Laser Software

    No, it's deployed by Microsoft ClickOnce using an Azure server. Updates are automatic and I've had almost zero issues with it.

    I suspect something on your system is blocking the download, the error appeared to indicate it's not even T2Laser but .net which comes from a Microsoft server.

    You could look at this to see if it helps: https://msdn.microsoft.com/en-us/library/ee308453.aspx?f=255&MSPPError=-2147217396

    Essentially you change a registry entry, "HKLM\SOFTWARE\MICROSOFT.NETFramework\Security\TrustManager‌​\PromptingLevel\Inte‌​rnet" to Enabled


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.