EleksLaser A3 purchased from Banggood (laser always on)



  • Yes, yes, I know you have seen that "laser always on" too much, but I can not figure this out for the flucking love of bacon.
    As stated in the topic, I purchased the kit from Banggood. The controller board is a Mana SE, the laser assembly is a "5.5W" with a driver circuit I can't quite track down a schematic of or datasheet - SW-LD49 V3.1 161121. Sey up to use PWM per kit instructions. After assembling this wonderful kit, I was able to use EleksCam to download the drivers and flash the hex from the software.
    I can control the movements with the steppers, that's no big deal. However, the laser turns on and stays on full power when the board's 12V input is turned on.
    I have rummaged through the forums and various other sources and still have no clue what's going on, but here's what I do know...

    • The only way to change the laser's power is to use the built-in target laser button on the laser driver circuit.
    • The TTL/PWM button on the laser driver does fluck-all.
    • Using a multimeter, I tested and confirmed that the controller board was outputting correct TTL/PWM signals and the power to laser was indeed 12V.
    • Even disconnecting the PWM/TTL wires from the laser driver while leaving the 12V input alone still has the laser on full.
    • Same situation as above, but pulled the "S" on the laser driver down to ground, still full power.
      Figuring the controller board was good, and the laser diode itself was turning on, I assumed the driver circuitry must be faulty and bought 2 new drivers. (What ever you want to call these https://images-na.ssl-images-amazon.com/images/I/71-7f-Q5ftL.SL1000.jpg rated for 5W)
      Since the new drivers only use TTL and not PWM, I took the initial 3 pin connector coming out of the controller for PWM, cut out the signal wire, and swapped the other end's connector with a 2 pin male, thus for use as the power input connector. Made myself a new lead connecting the motor output of controller to the driver, all good.
      Triple checked the connections, polarities, and signal outputs, all good.
      SAME. PROBLEMS. AS. THE. BEFORE.
      Disconnected the TTL lead leaving just 12v going to the driver, and it goes full power, yada yada, you heard this all before.
      tested with the 3rd driver, and same problems.
      No clue what is wrong. My body tells me it must be the laser driver, but I seriously doubt I got 3 faulty drivers all from different sources, all in as row.
      Anyone who knows what might be going on, please chime in. I have over 550 into this laser already. -,-

  • Active Member

    @ChewyJoe

    did you check the "laser on" button in elekscam, upper right quad of elekscam



  • Yes, it does nothing to the physical laser, but as stated, measuring the output with a multimeter off the board while changing that button does indeed change the signal.



  • I purchased an A3 laser engraver 2500 mW from Banggood and I have the same problem.
    With Benbox software I face your same problem while using EleksCam software I can move the axis manually, but when I start engraving it doesn't work.
    Of course I updated the firmware as explained in the instructions.
    Someone of you has a solution?



  • 1_1491211170782_IMG_20170403_071237r.jpg 0_1491211170782_IMG_20170403_071221r.jpg I tried several softwares: "Benbox v.3.7.99", "GRBL" and "EleksCam" (downloaded from Eleksmaker web site). I updated firmware as explained in the instructions.

    • With Benbox: I can move manually the axis and the laser is always switched on at maximum power. When I start carving, the axis are moving following the drawing pattern but the laser is always at maximum power and the result a completely burned wood surface!
    • With EleksCam: I can move manually the axis and the laser is switched off. When I start carving, even if the software follows the drawing pattern, the laser is switched on at minimum power and the axis don't move.
    • With GRBL it doesn't work.

  • Active Member

    @emanet
    post pictures of your settings in benbox and elekscam.



  • @mrmister These are the setting of EleksCam2_1491257503795_3.JPG 1_1491257503795_2.JPG 0_1491257503795_1.JPG
    And I tried also this procedure to reset the controller:
    http://forum.eleksmaker.com/topic/24/solved丨discuss-about-elekscam-didnt-work-issue-use-benbox-before-please-talk-here-and-here-is-the-newst-evolve/2

    My computer has Windows 8.1 64 bit



  • And Benbox settings are:1_1491257632751_ben2.JPG 0_1491257632751_ben1.JPG


  • Active Member

    @emanet said in EleksLaser A3 purchased from Banggood (laser always on):

    And Benbox settings are:1_1491257632751_ben2.JPG

    Change BOTH 12's on laser to 11.

    Also, make the change, run benbox see what happens. IF you want to then check elekscam you MUST flash the board under elekscam --> settings --> RST ROM


  • Active Member

    @emanet said in EleksLaser A3 purchased from Banggood (laser always on):

    @mrmister These are the setting of EleksCam2_1491257503795_3.JPG

    My computer has Windows 8.1 64 bit

    There should be messages in the space between the grid and Input Gcode Send Clear boxes. Can you post a picture with the messages that should be in that area?



  • Thank you, I will try to apply the changes in Benbox.

    About EleksCam, every time I click on "Driver" button and then I click "RST Rom"but it doesn't work. You cannot see the messages in the space between the grid and Input Gcode Send Clear boxes because I deleted them, but they are perfectly green.



  • Now it is working with Benbox putting 11 instead of 12.

    Thanks a lot!



  • @mrmister One year ago I purchased also this laser and I used it up to now with Benbox software.
    My question is: do I need to update the firmware each time to use this small laser engraver? Which kind of updating do I need to install?0_1491375269227_IMG_20170405_071557r.jpg


  • Developer of T2Laser Software

    Wow, that's a really old Benbox machine. If you attempt to flash the firmware it will not work anymore, my suggestion is leave it as it is.



  • @Zax Unfortunately, to work with the new "2.5 W A3 Laser Engraver" purchased now from Banggood, I flashed the firmware with file LX.hex.
    How I can go back to the old software to use this old small machine?


  • Developer of T2Laser Software

    I'm not sure what you are trying to achieve. Do you want to use EleksCAM with the Benbox machine?

    To go back to using Benbox, look for Benbox_Laser.60.328p.20150606.hex. It should be in the Benbox ROMS folder and see if that works.



  • Thanks a lot Zax.
    Now "2.5 W A3 Laser Engraver" is properly working with Benbox but it is not working with EleksCAM.
    What is the proper setting with EleksCAM?
    I clicked on "Driver" button and then I clicked on "RST Rom" button but still it doesn't work...



  • 2_1491464271948_3.png 1_1491464271948_2.png 0_1491464271947_1.png


  • Developer of T2Laser Software

    There is not one firmware for both, each software needs compatible firmware. T2Laser supports Benbox, Grbl 0.9 and 1.1 firmware so almost always works but for the most features 1.1 is the best. I understand EleksCAM is not supporting 1.1 yet, maybe in the future.


  • Active Member

    @emanet said in EleksLaser A3 purchased from Banggood (laser always on):

    2_1491464271948_3.png

    Post pics of elekscam and do not edit out the message that appear below the picture/graph in elekscam.

    For the driver its needs to install.

    After the driver you need to select let the RST ROM install.

    Your machine is working with benbox, this means your machine is working. The problem appears to be HOW to properly install elekscam


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.