Mana SE Bluetooth



  • I have an HC-06 Bluetooth module connected AND linked to the SE, But no machine control. I have tried bridging the two pads under the ardino board with the same no go results (no usb cable/pwr w/solder bridge connected). The green led flickers when T2 Laser sends a command, but no machine control occurs. I am running Grbl V1.1e. Do I need different firmware? Works great in USB but nothing in Bluetooth. I haven't tried it in Elekscam yet as Elekscam doesn't seem to want to run in WIN7 Pro 64bit on my laptop. So I don't have the Elekscam firmware. I can't seem to find the HEX file standalone to flash to the Ardino for a try.
    Suggestions? anyone?
    Black Canyon FX


  • Active Member

    are you running a laser with your mana se? Running a laser with bluetooth control is a really bad idea! Any loss in connection or slight interruption could cause the machine to stop and leave the laser at full power and one place until the work piece catches fire! If you are using this for the egg then it would be a cute novelty and not cause too many dangerous issues. Good luck on your moding



  • I'm running a 5.5w laser on an A3 Pro. And I am not stupid enough to leave an operating laser unattended AT ANY TIME. Bluetooth or not, that's a BAD idea. I just wanted to see it work in bluetooth 'mode'. I would prefer an answer to the question at hand, i.e. do I need eleksmaker firmware, a hardware mod, or what?
    Black Canyon FX


  • ElekMaker Develop Department

    Hi,
    The Bluetooth Connecter is in 5V GND RX TX Series , you need pair your two Bluetooth module first and set to 115200 bandrate.

    We will offer offical bluetooth module in few days , thxs for support

    Best Regards,
    Z



  • Hello 'Z',
    You wrote, "The Bluetooth Connecter is in 5V GND RX TX Series".
    The pinout drawing of the Mana SE shows 5V GND "TX RX".
    Which of the two is correct?

    I followed the Mana SE pinout drawing. The HC-06 Bluetooth module pinout is the same as the Mana SE
    drawing pinout. The HC-06 is paired, Baud Rate 115200, Ardino ROM is GRBL v1.1e, T2 Laser says it is
    connected on the HC-06 bluetooth COM port, and NO go (the two pads beneath the Ardino module are open,
    NOT jumped). With the HC-06 connected, both LEDs on the Ardino module are on when the power is applied (with
    no USB cable connected).

    Am I missing something? The green Ardino board LED blinks when T2 Laser sends a command but no
    machine response. What else needs to be done? Are the TX RX pins reversed in error on the Mana SE
    connector drawing and therefor reversed on my implementation? Is GRBL v1.1e the wrong firmware?

    Thanks for the help,
    Black Canyon FX



  • ? Z? (I'm not going to buy another bluetooth module, yours or otherwise. esp. if this won't work) Well? Any help you can give? Z?


  • ElekMaker Develop Department

    @BlackCanyonFX

    You can Try reversed the TX RX , what i say + - TX RX means you need connect bluetooth TX in to the TX(in fact which is mana RX Pin)

    and you can try use our lastest firmware instead of 1.1e~



  • @Z
    Sorry but switching Tx and Rx does not work. With them switrched there is NO lighted LED on the ardino board. The Mana SE pinout drawing is the correct pinnout it would apppear. I've no luck with the firmware either. I give up.

    Thanks for trying to help. If you figure it out, post the answer here please. Someone else may wish to try this.
    Black Canyon FX


  • ElekMaker Develop Department

    @BlackCanyonFX
    did you try to plugout the nano and try to weld up the two connecter , this is bluetooth power suply switch~
    0_1492327556599_upload-9c6eaad2-4946-4782-b26c-41a47ccb5394

    Best Regards,
    Z


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.