Problem servo motor



  • Hi, I have a problem to buy an A3 engraver and the electronics do not work correctly. The servo motors do not move. Only after removing one motor will the second motor rotate properly.
    The software was changed and it did not work.
    I changed the electronike from another A3 engraver and then the engraver works fine.
    Please answer what might be wrong with that electronics
    I bought an engraving from BANGGOOD, and they are writing to you in the forum. He writes with them for months and zero solutions.

    MY FILM
    Youtube Video



  • @darek

    Just changed Old eleksmaker board using benbox to a new mana se board with elekscam. I have same problem.
    It's working fine with Benbox an dold board.



  • There is not enough current going to the motors. do you see the small screw on the two stepper drivers? adjust it very carefully and slow untill you see both motors spinning


  • Developer of T2Laser Software

    The correct way to adjust the motor current is to measure Vref, it should be less than 0.6VDC (maximum 0.8V = 1A). Search for "A4988" to find more information on these drivers.

    0_1492430063668_motor_current.jpg


  • EleksMaker CEO

    Please test the motor one by one,Then try to swap A4988 module,Rule out the problem of A4988 and motor.If you setting no problem, General problems in in A4988 or line



  • Hi,

    i solved my Problem with this website:

    http://reprap.org/wiki/A4988_vs_DRV8825_Chinese_Stepper_Driver_Boards

    On my A4988-Board is a R100 resistor and the max. Stepper-current is 1.3A . So the formula for X-stepper-servo-Vref is max. Vref = 1.3A * 8 * 0.1Ohm = 1.04 VDC for X-stepper and for the Y-stepper-servo you can double VDC, because both stepper-servos are on one A4988-Driver and share the current. Because of the fact that Y1 and Y2 share one Driver, people report, that the one stepper-servo works when they unplug the other one.
    Hope my calculations are right :) But works for me like a charm.


  • ElekMaker Develop Department

    @freewheelin
    i am glad to here that , and your calculation was great.

    due to the Double Y motors are share the same A4988 Driver , If the belt is not too tight , you can maintain current , but if you cant move y Axis smoothly , you can try to increase the current~ nice work!



  • Driver was good. I will tell you how miraculously the atmega software has been damaged.
    I've programmed it once and it's ok


  • Active Member

    @Zax said in Problem servo motor:

    The correct way to adjust the motor current is to measure Vref, it should be less than 0.6VDC (maximum 0.8V = 1A). Search for "A4988" to find more information on these drivers.

    0_1492430063668_motor_current.jpg

    Would be willing to describe the process in more detail?

    Do I disconnect the driver from the mana and just place the tester ends on the positions you marked?


  • Developer of T2Laser Software

    No, you have to measure the voltage while powered and connected to the motor. Put the volt meter on D.C. and connect the leads as shown, on the GND and pot wiper (the screw thing). Then if needed turn the screw a very small amount and check again.

    Don't press too hard on the wiper with the meter probe as you can short it causing the driver to fail.



  • @Zax
    I adjusted the voltage but still shuddered.
    Gave up with multi meter and just tried adjusting the pot while moving the motor and while i could go from not moving to shuddering to only slightly shuddering it still did not move smoothly.

    So i gave up and went back to my L7 board with benbox, but my laser appeared to have died, it was glowing blue dimly (brighter than weak laser) but not burning. Tried it directly into 12V jack - same.

    I pulled the A4988 from my L7 board and it placed it in the MANA SE, and it all moved smoothly straight up.
    Looks like I had a dodgy A4988 board .
    It also cured my laser problem ????? Or is it just coincidence and my laser will die soon anyway.
    Doens't matter, I've got an A3 kit coming to replace my A5, and so I guess I'll have spare parts.


  • Developer of T2Laser Software

    Probably just a bad driver, I've heard of a few now so isn't too surprising.

    Spares are really good ;)


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.