Firmware upload error



  • When I upload Firmware default 1.1 it shows this massage
    Do you know how I can fix this problem?


  • ElekMaker Develop Department

    .. elekscam cant support 1.1 firmware


  • Developer of T2Laser Software

    @Salah What firmware do you have loaded now? Does it report Grbl Ready and work?

    The upload failure is usually due to the cable or Nano, sometimes using a different COM port, cable or pressing the reset button before uploading will fix it. Other times it means the Nano is corrupt and using the Clear EEPROM may help or you need a replacement Nano.

    I am not happy with the latest "Nano" on the Eleks Mana, it appears to have a lot more problems since they switched to a non branded microcontroller.



  • @Zax
    Hello zax
    Speaking of nano, how can I replace it.
    Do you mean that I need to replace the Arduino nano board?


  • Developer of T2Laser Software

    @Salah The Nano is the small board where the USB connects, you can replace with any other Nano clone.

    0_1525788929660_upload-97de0123-c7ad-4392-af61-93246748f873



  • @Zax
    I will replace it.
    Thanks a lot.



  • @Zax
    hey zax, i just purchased your software yesterday, i installed right away grbl “e” from the menu. All worked just fine, got a message that grbl e is ready etc. i tried moving motors by using arrows and it worked well.

    Then i tried to flash grbl “f” high freq pwm because the laser i ordered is ttl/pwm. I am very new in these things so i dont know if that laser would benefit from that grbl version, but i tried it. I thought that i can reflash grbl”e” back after. Boy i was wrong. No matter what i try, i keep getting “upload error 1/1” and cant see any flash progress, just another black window with some weird letters and numbers appears with the error message right after.

    Funny thing is that i can still connect laser, it still says that grbl “f” is ready and i can use laser.

    Is there ANY way how to reflash the controller board with grbl - e if i will experience any problems with current f version? Btw clear eeprom did not worked. Got the very same upload error 1/1 message.

    Thanks in advance!
    Rob.


  • Developer of T2Laser Software

    A genuine Arduino Nano can be flashed hundreds of times, but the latest Chinese clones (not using an Atmel microcontroller) have memory issues and are easy to corrupt. If you have another "Nano" you can use it to re-write the boot loader which may help. Sometimes they will work after letting them cool down for a while.

    There's actually nothing wrong with using that firmware, it's the same as the default Grbl 1.1e except it was compiled with 7.8kHz PWM (instead of the standard 0.98kHz). I would just leave it "as is".



  • @Zax
    Thanks a lot for quick response. Tbh i am pissed. You buy something, it works once and then it doesnt because chinese dont give a s*it about quality.
    Was browsing amazon and i am wondering if this arduino
    https://www.amazon.com/Elegoo-Arduino-ATmega328P-without-compatible/dp/B0713XK923/ref=sr_1_3?s=electronics&ie=UTF8&qid=1527121494&sr=1-3&keywords=Arduino+nano
    Would work. If yes all i have to do is just swap the old broken one with the one linked above? Or is extra soldering required?

    The thing is i really wanna solve this issue because i get “connected and grbl ready” message now. But one day.... and i am screwed

    P.s. i have to correct one thing. It was “grbl-f xy home sv” what i tried to flash over grbl-e. And it failed. Well failed - it says grbl-f is ready so... but i couldnt reflash it again with “grbl-f pwm” or anything else.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.