Firmware upload error

  • @Zax
    Would this one work for me?

    They say its with bootloader and its soldered.

  • Developer of T2Laser Software

    @redcore I don't see why not.

  • hello just had the same problem. i m running a eleksmaker a3 pro with atmel 328p . i was burning stuff for work when i decided to move back from 1f pwm to 1f laser axe.
    in the mean time i restarted my computer and t2 laser did an upgrade.
    i flashed the rom and then at the end i had this error message . since i can only make the laser go in one streight line what ever i do and whatever the rom i try to flash or even if i try to errase the rom i get error message firmware upload error.

  • Developer of T2Laser Software

    @znourf Why would you load LaserAxe firmware if you have an EleksMaker board? If you corrupted the Nano then you need to use Arduino IDE to reset the boot loader.

  • Simply because the laser axe allowed me to modify speed and laser power real time . Anyway , just found out that a spider had made it's "nest" on the nano clone :/
    So the bootloader must have a problem.
    Now i've got a uno and wanted to charge the nano clone but there is no ICSP on the clone.
    Anyone has an idea of the pining i should use to upload the bootloader to this "clone"

  • Developer of T2Laser Software

    @znourf You can load it directly from Arduino IDE, no need for ICSP or programmer.

    My default Grbl 1.1e or any of my Grbl 1.1 builds will allow real time overrides, the laseraxe firmware drives different pins for the axis so only works on their v2 boards (the latest v3 works with standard Grbl pins).

  • @Zax
    i tried that and got this with a clear eeprom command
    avrdude: verification error, first mismatch at byte 0x0002
    0x9c != 0x5c
    avrdude: verification error; content mismatch
    avrdude: verification error; content mismatch

  • Developer of T2Laser Software

    @znourf I know this is for an Uno but exact same procedure with Nano.

  • okay so i managed to save the arduino clone and even bought 2 others just in case. And today it's back to square one but all 3 are corrupt.
    So what happened? I was trying to launch a vector when the engraver set off and immediately stoped with the laser on at full power. I stoped the laser by turning it to low power mode with the switch then moved out to turn everything off.
    I turned the mana back on and nothingw as responding . I sent out to try an other nano clone but the same happened . Finally after trying to get it to work i tried a new mana board with a new nano clone. I didn't even have time for it to launch the laser stayed on. But this time the nano has the red light on al the time and gets hot.
    any ideas?

  • Developer of T2Laser Software

    @znourf Sorry, I have no idea what is going on with your machine. I have dozens of Nano's for different projects and never had any go crazy like you are saying. They are very reliable and I've found them extremely difficult to kill, even with poor ESD handling they don't seem to fail.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.