Laser allways ON, dont know how to continue.



  • Hello!

    Just bought elesklaser A3 5500mW and arrived this very monday.
    The building part was easy and fast, congrats, nothing wrong there. The laser it's conected with a 3 cable plug, Don't know why but I read its important.

    The problem is that I have the "laser allways ON" problem, I've seen more people asking about this and I read all the posts about it, and I have to say that now I'm more confused.

    There may be something I missed, and I'm pretty sure It's something to do with correctly flashing the board.

    First thing I did was installing Eleskcam, and did everything in order, I also installed both the driver and the RST rom. I did not turn the laser on until finishing this, but after that when powering on the laser the beam goes on and the board doesn't obey any laser order from the software.
    I unplug the laser cable and tried to move the motors, they all work perfectly.

    I begin reading and reading the forum, I tried installing T2laser and tried with the firmware 1.1 as it was mentioned in some post in the forum, that maybe with another software it may work, same error.

    Then I tried with Benbox, again updating the firmware as it's explained in the instructions, but still nothing.

    since I've tried the 3 possibly ways I'm stuck, and really don't know what to do now.

    I understand that for production process the laser must be in "allways on mode" so you can check it works before its shipped, and as I said everything works fine so far, but I did not manage to understand how to update the firmware in the board.

    I hope you can lend me a hand, thanks


  • Developer of T2Laser Software

    Does it have switches on the laser module? Some have 2, one is to switch between PWM and TTL, you want TTL mode and the other is for low power mode which should be off.



  • I supose you mean this two buttons.

    Question, if when turning on the laser it does goes on at full potencial, does it mean I have to press the TTL button to make it stop?, and in that case, does it means I have to do it everytime I turn on the machine?

    0_1491859419727_laser.JPG


  • Developer of T2Laser Software

    Make sure the low light switch is turned off and then change the PWM/TTL mode and it should work correctly. Once changed they will remain on the same setting.



  • done it, low light led mode is OFF
    Pluged on the board, pressed the PWM/TTL button and switched to TTL.

    It stays in that mode, but laser stills ON and burning. What should I do now?


  • Developer of T2Laser Software

    Disconnect the PWM signal wire (S) from the Mana board and ground it (connect to -) and if the laser still comes on you have an internal fault.



  • Ok, I went back to step one, reflash for eleskmaker software and IT WORKS!, laser stays off and obeys the software commands.
    Now I have another problem.
    Motors does move when told them so, and laser works when told it so, but when starting an engrave only the laser works, motors just dont do anything.

    I read it has something to do with the intertnational language settings, i'll try that now but I'm not exactly sure why.


  • Developer of T2Laser Software

    It is a bug in EleksCAM software. Grbl requires "." for numeric commands but if you are using some international languages it will use "," which fails. No such issues with T2Laser.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.