problems starting my first draw



  • Hello to everybody. I bought this machine last week. I have assembled it quickly. It's not difficult to do this but now I would try to make a sample drawing something. I can move the both axis X and Y, but when I try to launch a new draw, the machine don't start to move the pen. Why? Is there someone who can help me?

    Do you think the software is not good with win 10 european version? T2laser software is a better solution for my drawing machine? Coul i use it even if I don't have the laser mounted on it?

    sorry for my bad english.


  • Developer of T2Laser Software

    @tonisss I would think it should work with EleksCAM but I've never used it so can't help.

    T2Laser works great with the EleksDraw, I don't have a laser on mine either. Just make sure you set the firmware correctly per my setup instructions (found on this forum).



  • It's because of the Windows locale.

    When you move the pen around using the arrows EleksCAM is sending G commands without decimals, hence they work.

    When you start a drawing the G commands are sent with decimals, which MUST use the USA/UK decimal point. If you, like me, are in a country where the comma is used instead, the firmware will not recognize the G commands and just ignore them.

    EleksCAM does not seem to have an option to change this.



  • I've made it work by changing the system wide locale options for the decimal numbers, but it's a total PITA because it affects all applications.


  • Developer of T2Laser Software

    @pbotero No issue with T2Laser!



  • @pbotero Hi , I solved the problem. Thank you!!


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.