configuring axis dimensions in t2



  • This is a pretty noob question, but i can't figure it out.
    I Built my A3, with the control board on the front, and the home switches on the front left.
    I've downloaded the GRBL 1.1 from the T2 menu and installed the drivers, and enabled home switches in the software

    After this, I can draw sample shapes, and trace/engrave frame, but this only draws a box ~ 5 cm x 5 cm.
    similarly, i'm not clear on how to define home.
    can anyone confirm what should happen when i select Machine menu > home, or presets >home?



  • After loading the picture go to Settings in T2 and go to output size sub menu or click on the far right icon with multiple rectangular shapes and you can input the size of the pattern in mm for x and y with an option for keeping aspect ratio or not . That should do it.


  • Developer of T2Laser Software

    If the problem is simply scaling your image then yes, you can set the output size. If the jog keys don't move the correct distance you may need to calibrate the axis (steps per mm), that is done on the laser control screen under settings / calibrate distance.

    Home (Machine) is used if you have home switches, otherwise you set the work piece home either from the menu or right clicking the house icon.



  • Hi @Zax, thanks for that. just curious, I've wired up home switches, but when i try to download the firmware '1.1 w. home switches' it goes through a bunch of steps in terminal, but then fails.
    The home switches are positioned in the red circles below
    alt text

    If i try to send the laser to home, it moves to the position shown, which it defines as 0,0 in the controller.
    also odd, is that when i use the 'trace frame' tool, it drew the box indicated by the blue arrow, can you confirm the expected behaviour of this feature?


  • Developer of T2Laser Software

    @pow3r You should be using my default Grbl 1.1e firmware. It supports XY homing at lower left corner with switches wired in parallel to D9 pin.

    Then activate home switches in the settings menu and you'll notice the house icon is now red, indicating that the machine is not homed. Click that and it will do automatic homing and then set machine 0,0 correctly.



  • @Zax Thanks i'll try that tonight,
    just to confirm, is the position of the home switches as i have installed them ok/ in keeping with the expected positions in the firmware, or will the automatic homing process move the head around the frame until it closes these switches, regardless of which corner they exist on?


  • Developer of T2Laser Software

    @pow3r Your whole machine is backwards in my opinion :) as I consider the controller the back of the machine and the laser towards the operator but it doesn't matter. Homing is done to the negative of both axis, in other words it will move left until it hits the X-switch and then forwards until it contacts the Y-switch. That location is assigned 0,0 so all movements are now positive. This is the machine coordinates, your work piece or job coordinates are separate - this is where your job starts.



  • This post is deleted!


  • @Zax i ended up getting it all working by resetting all settings to default, which allowed me to home the laser to the bottom left (where the switches are)
    after this i've spun the unit round 180°, because inverting the x/y for manual jogging controls didn't play nice with the home position it seemed.



  • @pow3r Where did you find the drive snakes for cable control? I haven't been able to find them for a reasonable price. Thanks, bor


  • Developer of T2Laser Software

    @Bor I think you are asking about the "drag chains", they're cheap on banggood or aliexpress. You can probably get them from ebay too.

    https://www.banggood.com/search/drag-chain.html?sbc=1


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.