DXF curves jerky 1.1f CNC Z-XY



  • I did do that when I first installed 1.1f, but I'll try again tonight.

    Thanks Zax


  • Developer of T2Laser Software

    @DavidF If you are sending the same G-code then the only explanation is the Grbl parameters, since the CNC version expects a spindle and not a laser (by default) it makes sense you would need to change the parameters and enable laser mode to get the same result.

    If after doing these 2 things it's still different then we will have to dig deeper into how that could happen.



  • Hi Zax,
    Yes it was the same file, and I tried laser mode on and off with the same result. But I will try again and see if I can pin it down a bit more.

    Cheers

    David



  • Hi Zax, a bit more info. The jerkiness only happens when CNC mode is selected in the main page settings menu for cutting. With or without laser mode selected. In "normal" engraving operation all is fine and the curves are smooth.With 1.1e it's ok in both engraving and cutting modes.

    Hope that helps.

    David


  • Developer of T2Laser Software

    @DavidF Is this a laser or a CNC? If it's a laser, you need to select Laser Mode.

    0_1539629041186_upload-9b67369b-40d6-4b70-a9b8-ffa36b06b1e6



  • Is the elekmaker A3 laser with the optional Z axis. I fitted homing switches to XY and Z. You suggested I need the 1.1f CNC Z-XY firmware to home Z. The operation I am trying to do is cut through thicker materials using your depth change / pass option. For this you need to have CNC mode selected (with laser mode on). It is in this mode that the XY is now not following a smooth curve on a DXF. Your firmware 1.1e works fine. (but obviously doesn't home the Z)

    I hope that all makes sense?

    Cheers

    David


  • Developer of T2Laser Software

    @DavidF You have confirmed laser mode is enabled in BOTH places?

    above picture and on the laser controller...
    0_1539697543620_upload-b797459b-707c-4f88-919d-ccb295b5a048

    The firmware should be the same in this case. I run this one on my CNC and haven't noticed any difference in the paths.

    When you say "jerky" are you saying it's pausing at nodes / segments or is it like the resolution is lower for the path so it's drawing a circle as distinct lines and not smooth curves?



  • Hi Zax, confirm laser on in both places.
    I just checked using your sample 50mm circle and the effect is the same. It is drawing the circle as very small segments rather than a smooth curve. Only in CNC mode and only with 1.1f CNC Z-XY. simply changing to 1.1e without changing anything else and it's fine.

    Hope you can get to the bottom of it!

    Cheers

    David


  • Developer of T2Laser Software

    @DavidF Check your Grbl parameters, in particular $12 arc tolerance. It should be 0.002 (mm).



  • Hi Zax, it was 0.02mm. I changed to 0.002mm, but the result was the same. Still not smooth.

    Cheers

    David


  • Developer of T2Laser Software

    @DavidF This is really weird, there shouldn't be anything different between Grbl 1.1e and Grbl 1.1f that would cause jerkiness. I think the motion planner is the same code.

    Is the actual output different, can you visibly see it or is it just acceleration / deceleration on the vectors that is making it appear jerky? That may just be Grbl parameters, although using my send defaults should have made them identical.

    I'm not sure what else to try at this point, perhaps compile the latest Grbl 1.1 release with Z-XY homing enabled.



  • Agree not sure where I can go from here except to compare the parameters between the two versions. I would certainly like to keep the Z homing for sure. I'll try turning the laser right down so it it simply draws on paper and see if I can see the difference that way. But the movement is very noticeable on the curves.



  • Hi Zax

    Now we have a worse situation!
    I did compare the 1.1e and 1.1f CNC Z-XY gbrl parameters and there are no differences at all. I made sure that after loading each firmware I loaded the defaults and they are the same.
    Bigger problem is that as a test I loaded your 1.1f XY home firmware, and got a sync error at the end. However the firmware seems to have loaded. The big problem now is I can't load any other firmware. I just get a failed to load 1/1 error and the firmware has not changed. The main DOS box closes after a second, and another empty one pops up followed by the error. Of course it's not got the firmware to home the Z, AND it has the same problem as the CNC version - Jerky curves.

    I have the 3 axis mana board and there is no reset switch on it to press, and removing power doesn't help.

    Any advice on how to recover this situation??



  • Ok, I replaced the nano with the old one from the original board and we are back to sq 1. Can load firmware now. I have a spare Arduino uno, so I'll use that to reload the boot loader later.

    So we are still left with 1.1fCNC Z-XY as suspect...


  • Developer of T2Laser Software

    @DavidF Do you know how to compile and load your own firmware using Arduino IDE?



  • Yes. I have written code for Arduino on other projects. What do you suggest?


  • Developer of T2Laser Software

    @DavidF I would get the latest Grbl (v1.1f 2017-08-01 Release) from https://github.com/gnea/grbl/releases and set your required homing Z then XY if you want to match my firmware and compile to your Nano and see if it shows the same issue.

    These would be the only changes necessary:
    config.h;
    #define HOMING_CYCLE_0 (1<<Z_AXIS)
    #define HOMING_CYCLE_1 ((1<<X_AXIS)|(1<<Y_AXIS))

    cpu_map;
    #define X_LIMIT_BIT 1 // Uno Digital Pin 9
    #define Y_LIMIT_BIT 2 // Uno Digital Pin 10
    #define Z_LIMIT_BIT 4 // Uno Digital Pin 12

    I should have time to do this next week but since I'm not seeing the issue I would still have to send to you for testing and feedback.



  • Hi Zax, I am back working in China for a couple of weeks so can't do this right now, but I'll see if I can get the source into the IDE. I suppose I could add your homing code to 1.1e as well, as that version doesn't have the problem??

    Cheers

    David



  • Hi Zax

    Just had a look at the config.h file for both 1.1e and 1.1f and they are the same as far as the homing cycle is concerned. So what is different with your firmware? how come your 1.1e doesn't support Z homing? Is it just that you defined the cpu_map differently in 1.1e?
    Just trying to make sure I understand what I am doing before I attempt this!

    Any chance of a look at your config.h??

    NOTE: I just looked at the cpu_map.h and that seems to have the same pins allocated as you mention above, is it still necessary to paste your values into config.h?
    Agai just checking I understand all this before I break something:-)

    Sorry Zax, another question as I get in to this. In your load firmware section, you have about 6 different 1.1f versions. Are they all the same as the GitHub 1.1f, but the default parameters you load with them are different, hence your various suffix to tell them apart.

    Cheers

    David


  • Developer of T2Laser Software

    @DavidF The only difference with my default 1.1e is I disabled the Z-homing and set X/Y to use the same pin and home sequentially as it's easier for people to connect one wire (D9).

    config.h would look like this:
    #define HOMING_CYCLE_0 (1<<X_AXIS)
    #define HOMING_CYCLE_1 (1<<Y_AXIS)
    #define HOMING_FORCE_SET_ORIGIN

    cpu_map:
    #define X_LIMIT_BIT 1 // D9
    #define Y_LIMIT_BIT 1 // D9

    I don't keep the files, but as you can see the changes are very minor so I just edit and compile. The various firmware are all basically the same, depending on the machine some pins may be changed in the cpu map or the homing sequence etc. but I always use the same basic parameters.

    I always use the latest version from github and if I notice updates that are necessary I will also recompile my default to get the new changes but since 1.1f didn't really have anything I considered "necessary" I left the default at 1.1e. Any new firmware I've compiled would use f, which is why you see a combination but I haven't seen the problem you are having in my testing.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.