T2Laser Software - Introduction


  • Developer of T2Laser Software

    @Torchit1 Wow, that's an impressive test file.

    It is difficult for me to tell what is causing this issue, it could be electrical noise resulting in an overstep or it could be Y-axis backlash "catching up" and causing it.

    You mentioned disabling bi-directional mode, so it sounds like you have a backlash issue on the X-axis. I can run at 3000 with no issues so your machine may need some mechanical adjustments, perhaps the wheels are binding?

    Steppers with encoders would probably not help, or what I suspect you are talking about are the servo motors which have step and direction drivers so act like steppers. The problem with servos is they tend to hunt without good control logic, but are generally the better technology.

    Have you tried setting the Y-max speed to 1000 so you can use 2000 or more for the X-axis and the Y will remain lower? That may be a reasonable band-aid. To do that enable debug mode and type $111=1000 then press enter.



  • @Zax Ciao Zax, ho fatto tutto, messo il tuo firmware, calibrato macchina ora è tutti ok, solo che se stampo immagini a scala di grigi fanno un po' schifo o sono troppo scure e se schiarisco non si vedono i dettagli dei volti, hai qualche consiglio da darmi su impostazioni e cose varie? Tipo potenza avanzamento vorrei fare uscire una bella foto in scala di grigio, grazie mille


  • Developer of T2Laser Software

    @Spiderman It is difficult to say without seeing the result, but possibly you need to enhance the image contrast to made details show up better.



  • @Zax Ciao Zax, ho fatto un po' di prove su vari materiali, cartone legno vetro alluminio, con risultati soddisfacenti (prima o poi riuscirò a caricarli giuro), volevo solo sapere se faccio giusto : io tengo velocità alta intorno ai 2300 e poi faccio delle prove sul materiale su cui voglio laserare la foto con una scala di grigi e regolo la potenza massima finché la scala non mi soddisfa e poi la faccio disegnare. Però mi sorge un dubbio da inesperto magari è normale ma su carta bianca non succede nulla o prende fuoco o niente come mai?


  • Developer of T2Laser Software

    @Spiderman That works but I do it a little differently. I leave laser power at max and increase feed rate as this is the fastest method. If feed rate is too high, say 2500 then I start reducing the laser power.





  • This post is deleted!


  • alt text



  • alt text



  • alt text



  • Ciao Zax volevo chiederti ma se aggiungo asse z con mandarino posso usare il tuo software per fare fresatura?


  • Developer of T2Laser Software

    @Spiderman said in T2Laser Software - Introduction:

    Ciao Zax volevo chiederti ma se aggiungo asse z con mandarino posso usare il tuo software per fare fresatura?

    Yes, T2Laser supports 3-axis machining.



  • Ciao Zax ho un paio di richieste, il tuo software supporta il firmware Marlin kimbra, e se prevedi un ampliamento per la stampa 3d, sarebbe fantastico


  • Developer of T2Laser Software

    @Spiderman said in T2Laser Software - Introduction:

    Ciao Zax ho un paio di richieste, il tuo software supporta il firmware Marlin kimbra, e se prevedi un ampliamento per la stampa 3d, sarebbe fantastico

    No plans to support 3D printing, but to run machines with lasers - yes!



  • Ciao Zax ho un problema anzi 2, allora uno è che quando stampo una foto di dimensioni ridotte tipo 8x5 cm tutto ok quando invece voglio fare un formato tipo 15x10 arriva ad un certo punto (mai lo stesso) si blocca il software dando alarm e nient'altro appare il lucchetto da sbloccare in mezzo alle freccie di movimento manuale e mi chiede se voglio ricominciare da capo, e non mi specifica il problema, poi l'immagine presenta delle righe di passata che non mi piacciono ma non so come risolvere ti allego foto



  • alt text


  • Developer of T2Laser Software

    The error is a response from Grbl that something went wrong, this is usually due to communications or memory problems with the Nano. T2Laser stops your machine and shows the alarm "lock" for safety, you can disable the fail safe feature and also use Simple Streaming mode to see if the problem goes away.

    There are many possible causes.

    Electrical interference from the motors (ground the system)
    Low quality USB cable (without filters)
    Computer or ports going into a sleep mode (disable all power saving)
    CPU hungry programs running in background when system appears idle (anti-virus, backup etc)
    Nano overheating and having memory glitches (use a real Atmel chip as many of the Chinese clones exhibit this issue)

    Since it is random, we know it is one of these or similar and not the G-code.



  • Hi Zax I just bought last night the T2laser software for my elekdraw, do you have any tutorial on how to use it?


  • Developer of T2Laser Software

    @Bartolome-Cabrera I sent to you via e-mail but it's also on this forum under the T2Laser / EleksDraw section.

    http://forum.eleksmaker.com/topic/154/eleksdraw-assembly-and-setup-for-t2laser


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.