T2Laser Software - Introduction


  • Developer of T2Laser Software

    @bandanabandit T2Laser has a lot more functionality, I can't comment vs other software. Like anything, you get what you pay for.



  • @Zax had a play with t2l and it's pretty dam good what I can see on the trial. I will purchase it Wednesday when I get paid 👌👊



  • Hello Zax!
    I'm already using the full version of T2 (thanks for it, very good program) I'm just moving slowly because of the language.
    Now I'm a little bit jammed, I would like to ask if I can write text in sketch mode in several queues, or just one by one, so that the laser is out of the way.
    It may be that only text written in another program can be converted into multiple sketch fomata.

    My other question if I went to gcode (save gcode, save machine gcode) (ncfile) does not accept (load gcode)

    Thanks,
    I look forward to helping you


  • Developer of T2Laser Software

    @zoli Yes you can enter multiple lines, there are 2 ways. You can use the pipe symbol "|" to separate lines or you can use the parametric input screen (type the first line, select it and then press P) and enter it normally like a text editor.

    You can save G-code (this is the T2Laser native format) and load it later, either double click on the G-code window or use the Load G-code menu. The Machine G-code is post processed, this is for sending with other software and not for reloading in T2Laser although you could. All G-code is text, you can change the extension if needed when you save.



  • Köszönöm a választ,nagy segítség,megpróbálom.



  • Hi Zax,
    I recently installed T2 lasers and since yesterday I have a problem that I do not understand.
    The axes do not move anymore, everything else responds to the commands.
    I tried reinstalling the drivers and the software but they do not work anymore.
    Will you help me then? thank you


  • Developer of T2Laser Software

    @Usti74 Does the laser work correctly?

    Do you get the "Grbl Ready" message when connecting?



  • Hi Zax,
    Yes
    Connected COM3 115200
    Grbl Ready

    "Laser Pulse" works correctly!

    Only the axes are dead. I also tried on another pc but nothing




  • Developer of T2Laser Software

    @Usti74 That's strange then, you know it has power since the laser works but none of the motors move. I'm not sure how that would happen, time to do some diagnostics work.

    Put it in debug mode and see what firmware you have loaded, hopefully my build of Grbl 1.1e.

    Try disconnecting all but one motor and see if that works, wondering if there's a short or something in the cable.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.