New EleksDraw Plotter but the Stepmotor dont work automatic



  • New EleksDraw Plotter but the Stepmotor dont work automatic

    I got the Eleks Draw two weeks ago and yesterday had finally had time to build him together. Have the new ROM played on the motherboard, the command A1 set so the pen lifter works and he works.
    Now I would like to print a picture, but do not move the step motors, but manually by software they run. I install the eleks cam software from the banggood.com Site on WIN 10.And the USB driver CH340 is installed.



  • @caracol2005 if your steppers are moving manually but not when running a program that sound like you need to change your regional settings to use a . Instead of a ,



  • I had same problem. Change , to . in system settings =]



  • Thanks at all ,

    this , to . dot is a Windows bug since 2012 but i think in WIN 10 was this from MS remove.
    But MS is very very slowly in such things


  • Developer of T2Laser Software

    It is not a Windows bug, it is an EleksCAM bug.

    T2Laser does not care what setting your computer is using, it still sends the correct G-code to your machine. The developers need to fix this in EleksCAM, and I would say it's the #1 bug they should fix immediately.


  • Active Member

    Sorry, @caracol2005.

    This is not Windows bug at all. Don't blame MS for that. Blame national habits. :D As G-code interpreter in EleksMaker machines does not understand coordinates that are described with commas, it not moves motors. And that is as it must to be, as coordinates with dots are standard to G-code, it is just faulty EleksCAM program that does not send them correctly if some kind of region uses commas in decimal numbers instead of dots that is common to computer world since it's beginnings. It is easy to fix problem and I don't know why EleksMaker did not done it yet.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.