problem after update - no movement



  • hello
    after buying and installing this Nano on the advice of ZAX : https://www.amazon.fr/AZDelivery-Nano-complètement-compatible-V3/dp/B01MS7DUEM/ref=sr_1_8?__mk_fr_FR=ÅMÅŽÕÑ&keywords=Arduino+nano&qid=1556441994&s=gateway&sr=8-8

    I made the update in 1.1 (1.1 default using T2laser)
    I do not have any movement of the motors (in manual or in engraving mode)
    T2laser detects the nano without problem, it sends the Gcode but nothing moves
    it's works with old nano card (i just make test)


  • Developer of T2Laser Software

    @tazgc30 Is it inserted correctly?

    When you say it works with the old Nano card, do you mean the original Eleks Nano clone works?



  • @Zax with original nano card provided with eleks 3 axes main card (in grbl 0.9)


  • Developer of T2Laser Software

    @tazgc30 You are using that same controller board and just swapping the Nano, correct?

    It works with the original but not the replacement, although the replacement is connecting and Grbl is running. This doesn't make much sense unless it's not plugged in correctly.



  • @Zax yes, same controller card, I just switch the nanos
    update in 1.1 (default) without any errors
    T2 connects to the card (for him no problem detected)

    OUPS !! i just find something on T2 i try and come back with news



  • @Zax ok
    i try with GRBL 0.9 but no change
    I tested with GRBL 0.9 but same
    message on T2:
    Connected COM5 115200
    Grbl 1.1e Ready

    or (in 0.9) :
    Connected COM5 115200
    Grbl Ready

    but no manual or automatic movements
    the nano card is correctly connected


  • Developer of T2Laser Software

    @tazgc30 It won't turn the laser on/off either?



  • @Zax the laser is active 100% permanently even if I click on the button to cut it on T2



  • i try another upload in 1.1
    i have this lines after reconnect main card on T2

    Connected COM5 115200
    Grbl 1.1e Ready
    Ready
    $0=10 Step pulse, microseconds (10)
    $1=25 Step idle delay, milliseconds (25)
    $2=0 Step port invert, mask (0)
    $3=0 Direction port invert, mask (0)
    $4=0 Step enable invert, boolean (0)
    $5=0 Limit pins invert, boolean (0)
    $6=0 Probe pin invert, boolean (0)
    $10=1 Status report, mask (1)
    $11=0.010 Junction deviation, mm (0.020)
    $12=0.002 Arc tolerance, mm (0.020)
    $13=0 Report inches, boolean (0)
    $20=0 Soft limits, boolean (0)
    $21=0 Hard limits, boolean (0)
    $22=0 Homing cycle, boolean (0)
    $23=0 Homing dir invert, mask (0)
    $24=100.000 Homing feed, mm/min (100.000)
    $25=1000.000 Homing seek, mm/min (1000.000)
    $26=250 Homing debounce, milliseconds (250)
    $27=1.000 Homing pull-off, mm (1.000)
    $30=255 Max spindle speed, RPM (255)
    $31=0 Min spindle speed, RPM (0)
    $32=1 Laser mode, boolean (1)
    $100=80.000 X steps/mm (80.000)
    $101=80.000 Y steps/mm (80.000)
    $102=80.000 Z steps/mm (80.000)
    $110=4000.000 X Max rate, mm/min (5000.000)
    $111=4000.000 Y Max rate, mm/min (5000.000)
    $112=6000.000 Z Max rate, mm/min (5000.000)
    $120=800.000 X Acceleration, mm/sec^2 (800.000)
    $121=800.000 Y Acceleration, mm/sec^2 (800.000)
    $122=5000.000 Z Acceleration, mm/sec^2 (5000.000)
    $130=400.000 X Max travel, mm (400)
    $131=300.000 Y Max travel, mm (300)
    $132=200.000 Z Max travel, mm (200)


  • Developer of T2Laser Software

    @tazgc30 I have no idea then, it seems unlikely a new Nano would be defective and you are able to load firmware and run the G-code just the outputs aren't behaving as they should - or - there's something wrong with the connections (some Nano's have the USB on the different end, make sure the pins are all aligned and not just the USB).



  • @Zax ok i look, make some test, and i see, buy a new one maybe
    thanks for your answers



  • @Zax just one more thing
    do you have a tutorial (video or other) to engrave a grayscale image in CNC mode (each hue difference corresponding to an engraving depth) with T2


  • Developer of T2Laser Software

    @tazgc30 The default setting is 3D, so just enable CNC mode and set the maximum depth (that corresponds to black, so invert if you want to make a relief). I would suggest using a fairly small depth at first, a lower resolution (larger value) will produce a smoother result but less detail (keep it at or below the cutter radius for the best result).



  • @Zax thanks


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.