How to set up Eleks machine limit switch in T2 Laser


  • Active Member

    This post is deleted!

  • Active Member

    This post is deleted!

  • Developer of T2Laser Software

    No. You can use any firmware you like. T2Laser supports Benbox, Mana and any Grbl 8 or higher. It's just that the firmware I provide always has D9 as the home pin for both axis.



  • @Zax so if i solder a wire onto the nano d9 and onto gnd and put a limit switch on the other end of the wire then run the software and press the limit switch will this halt my program or do i have to do something else before hand
    thanks for any help


  • Developer of T2Laser Software

    They aren't limit switches per se, they're home switches. Let me explain how it works.

    You put one normally open switch on each axis at the 0,0 (lower left), wired in parallel between D9 and GND.

    Enable home switches in the menu and the house icon will change to red.

    Click the red home icon and the machine will move to the left until it triggers the X-axis switch, then it backs off until the switch is open again. Then it moves forwards to trigger the Y-axis and backs off slightly.

    Your machine coordinates are then set to 0,0 and you can use absolute positions (presets).

    It's still possible to use work piece home but the machine coordinates are always tracked and available for exact positioning. If you set your machine size (change the Sketch size then click the menu option) it will setup soft limits, which your machine will never go beyond and crash.

    So you have homing and limits (via software) all for 2 simple switches.



  • @Zax do i have to do the same if i am using t2laser software or was you referring to that software
    thanks for your help


  • Developer of T2Laser Software

    Yes, I was referring to T2Laser.

    If you prefer to use some different configuration (limits, 2 pins etc) those are all possible but you would need to compile your own firmware with the correct options enabled. T2Laser will still work with them.


  • Active Member

    This post is deleted!

  • Developer of T2Laser Software

    @mrmister No, that's a little different. You use that option if you have + and - limit switches on the SAME axis wired in parallel as otherwise Grbl wouldn't know which way to move.


  • Developer of T2Laser Software

    How do you want to have the switches configured?

    If you send me your email address in chat I will change the necessary files and send them to you with explanation for each change.

    For most people I would suggest using my firmware to begin with and putting both home switches on D9 to simplify things but you obviously have some idea what you're doing.



  • @Zax meaning that D9 pin has internall pullup activated?


  • Developer of T2Laser Software

    @jorgemarmo Yes, you just connect the switches to ground.



  • Hi Zax, thx again for the answer!



  • I'm using long arm home switches and T2laser doesn't back off far enough to do the final home run in. They're an easier installation than other setups I've seen but I get an error after the first back off. Any way to get about another 1/8th or 1/4inch of back off to alleviate the error warning while homing? Spacebar21


  • Developer of T2Laser Software

    @Spacebar21 It should back off enough to disengage the switch, no matter how long the arm is but if you prefer you can edit the $27 value.

    My default is 1mm, so $27=1

    The others are the homing speeds, called feed and seek. Seek is the initial contact and then feed is the slower second time.

    These are my default values.
    $24=100.000
    $25=1000.000



  • Worked! Thanks. I needed 4mm as my arms are pretty long. Works pretty reliably too!


  • Developer of T2Laser Software



  • @Zax hahahahaha



  • Hi guys. I installed my limit switches and even soldered them very well. But, once I tried my laser it was cutting mirrored images. I resolved this by inverting the axis. Great now it cuts well but after installing limit switches, then home them to 0.0 then move the laser into position for cutting. It shows my coordinates in negative. I was looking into the settings of grbl but don't know which $$ to change.. could you help me ? 0_1511358335244_IMG_20171122_001031.jpg 0_1511358440084_IMG_20171122_001024.jpg
    Will it be better to just move the whole board and limit switches to the opposite corner ? (I don't want to do that kind of :/ )


  • Developer of T2Laser Software

    @rolx Usually the control board is at the back but it doesn't matter as long as your home switches are at located at what you consider front left.

    Once it locates the home switches the machine coordinates should be set to 0,0. If there's an offset I would clear them using Clear Grbl Positions in the Machine menu.

    If the switches are positioned as limits rather than home switches you can still use them, but would need to change some parameters and then setup one of the custom buttons to go to your home position and reset the workpiece 0,0. Yes the machine coordinates would be negative but this is no problem and actually fairly normal in the CNC world.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.