$100, $101 and $102 Settings



  • First off, just wanted to introduce myself and say thanks for all the help that has been already put on this forum. Just got my Eleksmill a few days ago, been having fun learning how to run it. This is my first live experience with such a device and so far it's working, but not without a few hiccups along the way. Was able to solve my z axis issue thanks to previous posters, thank you. I upgraded the board to 1.1 GRBL so that it would support homing on the Universal G-Code Sender program and among other reasons. I forgot to copy the settings for original setup, hoping someone wouldn't mind giving me a print screen or just type your settings so that I can have accurately dimensioned parts. Looks like 1.1 comes default set to 250 for all three.

    For anyone wondering how to find that, simply type $$ into the command line, either in EleksCAM or Universal G-Code Sender. Thanks.



  • Well, heck... I thought that this was a fairly simple request.. All one has to do is open Elekscam, type $$ into the command bar, copy and paste lines 100-103 to the forum. Assuming that this is an unmodified GRBL Eleksmill that is being copied from.

    I would calculate it, but I have no data about thread pitch etc. Having reviewed the rest of the forum, not finding any clues either... Would greatly appreciate taking all of 1 minute of your time. Thanks.


  • Active Member

    It does seem like a simple request... unfortunately there arent really any active eleksmill users yet. I think there have been a few questions that elekslaser users have guessed at. Sadly I cant guess at this one for you. I hope an eleksmill user can help you.


  • Active Member

    This post is deleted!

  • Developer of T2Laser Software

    The mill uses 400 steps per mm for all axis, if that's what you are asking. You should also reduce the acceleration values and disable laser mode.



  • Thank you Zax, 400 mm it is. Will test that shortly. Mrmister, reloading GRBL? Thought about that, but there was no guarantee that what I uploaded would be correct.

    Appreciate the help!

    Edit:

    Forgot to mention that currently the maximum rate is set to 500 and acceleration is set to 10. Should be sufficient, right?



  • 400 steps seems to be spot on, again, thanks. Have a 3d printer coming soon, I'll be able to model and print upgrades, like a dial indicator holder, to test accuracy and runout.


  • Developer of T2Laser Software

    Yes, 500 and 10 is very conservative and ideal for mill.



  • You could of answered this question yourself by putting the eleks rom firmware on and setting it for mill and read the values off and then replace the firmware if neede. I was going to do this for you as I have a few spare nano's around but have been away all weekend.



  • Yep, that would have been great if I'd thought of that before updating to 1.1. Lesson learned. While I may be reasonably computer savvy, this is my first introduction to any kind of cnc milling. All the youtube/forums out there can't prepare you for practical experience. Nonetheless, I am still appreciative of all the help, especially from Zax.



  • Just read my post and realised it could possibly be taken the wrong way.
    That was not my intention I was just trying to explain it would be possible to do it that way as it still is, you can change the firmware then put 1.1 back on after you have found the values you need.



  • Nah, you're fine. If you meant that the software comes with the original firmware, I guess I missed it. I'd thought of that too, but couldn't find it. Seems to worked out well in the end, so far.

    Now working on dialing things in. Which means taking it apart and making sure the bushing are taking out as much backlash as possible, loosening bolts up, moving the slide assembly to one side, then tightening them down, to minimize rubbing and excessive friction. Wonder if I could find better, smoother rods, not that this machine needs it.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.