Laser module connection



  • HI folks,
    I just bought and already assembled the A3.
    I bought it without a laser, since i still have some from a previous purchase of a mini mill where i also got a 2500mw laser.
    make is exactly the same. Now i had to see that:

    1. the connection is different: Three cables coming from the control board and end up in the white connector/ while the cable to the laser has a 2 poles round connection. Can i just use the black and red cables and just ignore the yellow one?
    2. the laser is identical. also the fan, but those ones i see here on the eleksmaker site all have another board on top. mine doesn't have. what is the function of this board? will it work for me to connect my laser without this board or is that needed. If yes, could i purchase this board somewhere ?

    Every input would be helpful. thanks guys!
    0_1496454728305_03.06.2017 09-50-18.jpg 0_1496454714037_03.06.2017 09-48-07.jpg


  • Active Member

    so the answer to your questions is no. The 3 wire set up is a constant 12v +, ground, and a pulsing 5v (that is your 3 wires). You need a pulsing 12v and no 5v.

    what you need to do is connect your 2 wire laser to the 2 wire connection on the board labeled motor. you may need to cut the 3 wire connection off and just solder them on or get a new 2 wire connector. The board output labelled motor is for 2 wire lasers and will pulse it as necessary.


  • Developer of T2Laser Software

    nottingham82 is correct, just connect your 2 wire laser to the MOTOR connector. Center pin is + and shell is -.



  • Alright!

    this means unfortunately that i need to get myself a 2 wire connector to the plug into the board (motor).

    wouldn't it be easier to solder the 3 wire connector off and the plug there from the laser and fix the related poles together?


  • Developer of T2Laser Software

    The "laser" connector has permanent 12V, ground and TTL signal.

    The "motor" connector has a switched 12V (using PWM via the MOSFET) and ground.

    You can't use the 3 pin connector as your laser would be constantly on with no power adjustment.



  • OK, that makes sense.
    But one thing i don't get.

    This is the connector Eleksmaker delivers and also shows in the connection plan to use. Is this what the board on their provided laser is for?


  • Active Member

    @micc exactly. The board is so that the 3 pin will work. It is a whole different concept on metering laser power. Without the board the three pin socket wont do anything for you. If you hooked it up by just soldering into that wire you would get a laser that never turns off. This would burn you a nice solid square everytime with no image. Or if you got the wiring wrong you would get a laser that never turns on.



  • Unfortunately here comes the next thing and i need to bit tell about the background:

    The laser doesn't work. I followed the procedure on FAQ. And i can not make the test under " Laser doesn't work" because i don't have the connection to the three wired one. (there actually i find my last comment/ question explained).

    I just can't get the laser to run. I used a two connecter that i have from the same source as the rest that comes below.

    Further tests i did:

    I have this laser because i bought a mini mill before, from a chinese supplier, that is also been discussed on the bbl forum for having changed their pin setting and with that only their delivered software would work, which is more or less useless.
    Well, i gave a damn and bought a new card, since of course i played around with theirs and messed it up by flashing it with a standard GRBL.
    The 3 axis card i bought is from elekscam and since then it seems the mill works fine.

    It has the same connection to the laser tho (as the card that comes with the A3, and i never checked the laser with it.

    With that 3 axis card, i just used now the motor of the mill, no problem.
    connecting the laser, nothing happens.

    I am pretty sure the laser should not be broken.
    Last time (before the card change on the mill it was working)

    Anybody can give me some ideas on how to check that?
    Because now, i am helpless and thing about just to bring some 12V current to the right poles on the laser. But that mit destroy it then possibly. Or is it most likely it is already broken?

    How can i check if my problem is the connection, or a damaged laser...



  • @nottingham82
    i was just writing my last message, when you kindly replied again.

    that was the thought i forgot to add. what if the dear manufacturer of that mill, also made here a pin switch. It would never turn on...



  • Well, i just did it.
    laser works. used black and red of the 3 pin connector and just turned the card on like in the test that is described in this thread " my laser isn't working".

    So, hmm. means i need to check on other things.


  • Developer of T2Laser Software

    I'm pretty sure the laser you have is NOT an EleksMaker module.

    So you connected it to the laser + / - and it's always on, that's what it should do since that's just 12V.



  • @Zax : yes, this i just did to check if the good piece is still one among us, or if it mysteriously went to heaven.

    I understood your and Notthinham82's point that it shall be connected over motor. But i couldn't make it work there so far, so i wanted that to check first,

    Another option is in fact if the previous manufacturer switched the poles also here so it only works with their board. Assumption, but i will check on that tmrw.

    If that's not the case then the wiring should be alright and it is about driver, software or else there related problems.


  • Developer of T2Laser Software

    If you have a meter, check the motor connector gets 12V when you turn on the laser and 0V when it's off.



  • Now i am at the same point as before. Connected laser into the motor plug (2 pin connector) checked before with black and red from the 3 pin connector if the laser gives light. it does.
    But turning laser on via software does not work. The mill motor funny wise works. Which would replace the measurement with the meter.
    Very clueless...


  • Developer of T2Laser Software

    It sounds like the MOSFET on the Mana SE board is blown, it is turned on by the Nano (D11 pin) so you've replaced that and still have the same issue.



  • @Zax Thank you for so much help! really appreciate that!

    About that point i need to ask. If a certain part on the board is blown.
    How come that the mill turns on, if i connect but the laser not?
    One further test i can do is to connect completely with the 3 axis board.
    put the nano back and try to turn on the laser.


  • Developer of T2Laser Software

    If the motor port is working for the spindle (mill) motor then it should also work for the laser.

    Do you have the laser power reversed? That's all I can think.



  • Just tried. Same.
    Laser does not turn on. The mill motor did.
    One thing i observed. In T2 i changed the laser power setting. slowly down form 1000. And up again. the board LED (blue) was blinking accordingly. And a beep in same rhythm was to hear.

    A second time i couldn't go down and up again. Blue LED stayed on all the time. No sound. Motor does not respond anymore....
    That was all the 3 axis board.
    Switch back to the mana SE.
    After set up, and pressing the power button of the card the motor immediately starts and can not be turned off.

    Restart software. disconnect USB, and power cable.
    Even closing the software does not stop the motor spinning.

    Disconnect motor, connect with laser. The blue LED starts blinking again.
    But laser Off button shows no response. Also the Step motors don't properly respond. They respond with time delay and very aprupt, tiny movements.

    After restart of the computer, the step motor react normal, the mill motor is still running, from turning on the board. it does not respond anymore to settings (strength, and on off) even they are listed in the command area.
    Switch to the laser, the LED on the board blinks again.

    Here seems something to be very wrong. Can't be that by connecting i destroyed two boards. Just can't be. I did nothing fancy with them



  • Wow! what an odyssey!!!

    You were totally right, that the poles were switched.
    The laser works now. to 100%. And never turns off.

    Now i have the situation that the stepmothers work as usual but the laser doesn't get the signal to turn off or on.
    Not in elekscam nor t2. Only the switch off the board makes it turn off again.
    tried flashing. 0.9 and back to 1.1.
    Disconnection all cables and turn on again.
    restart the computer, using my other computer.

    If the board (or better the boards, because it looks like the 3 axis one got effected too) are now dead, then i did it either with reversing the laser or by connecting the mill. really?


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.