Nothing works (anymore?)



  • The other day i was writing here about the possibilities to
    connect a NON - Eleksmaker laser to the A3.
    And i was pretty confident to get that problem solved today but i needed to make a unfortunate discovery: Nothing works anymore.

    Before i was able to connect properly with Elekscam and also a trial of T2, and some other software i wanted to try.
    Now, none of the softwares connects properly to the A3 anymore:

    • Followed the procedure again that is mentioned here under "frequent issues..."
    • red LED glows when USB is connected, blue one when power is on.
    • the Step-motors "tighten" when power on.
    • the right USB port is listed in the programs.

    But that's all what seems alright.

    • Failure message Elekscam: "Find Serial Ports fails, Pls make sure you are already connect Eleksmaker CNC device. Then click [refresh]"
      Other software: " COM3 did not make the right response, the connection has ben disconnected"
      T2" is somehow connected how it says, but it doesn't state the usual GRBL thing.

    Of course with this the rom can't be flashed, the machine can't be selected.

    What i tried:

    • change USB port and cable.
    • connect and disconnect stepmotors and power from Card.
    • Follow the procedure again (deinstall driver, install again, ...)
    • another computer (windows virtual drive on a mac/ first one PC)
    • try different softwares

    Nothing made any change.
    can anybody give me ideas what that is now?
    I am really confused because two days ago at least all that was working..


  • Active Member

    @micc

    disconnect everything. Plug in only the nano to the usb, what color light appears on nano board.


  • Developer of T2Laser Software

    Remove the Nano from the board and connect to PC with USB cable, if you get the "Grbl Ready" message then the board is bad (most likely the capacitor on the input is shorted).



  • @mrmister I unplugged power and all stepmotors.
    The light is red
    (well,there is a little bit of green light also shining) but red is bright.

    @Zax If i unterstand right, then the "nano", is the small long board that is sitting on the mana se, and where i plug the usb in.

    took that off the mana, plugged the usb.
    Eleksmaker and T2 show the same as before.

    Thanks for your fast replies.


  • Developer of T2Laser Software

    If you don't get the Grbl Ready message when the Nano is removed from the board, and you are sure the COM port and Baud Rate are correct that indicates Grbl isn't running. What happens if you try to flash it? Do you get any errors, like "device not ready"?

    If so the boot loader may have been wiped, so you either need a replacement Nano or try to flash via ISP/ICSP if you know how to do that.



  • Ok, i checked now all software that i had about differences. But it all seems to be all the same.

    I made another test. i still do have a mana 3 axis card. and there the green LED is on and it all works. i could take that first. but that is from my mini mill and i would get a replacement.

    i have one more ( the original from the laser axe mill, where i flashed the original GRBL 1.1e and with that it did;t go anymore with their 3 axis board.

    could i use that one? It has a different USB connector, and not sure if that works with the mana se.
    0_1496683851915_IMG_9844.jpeg

    Flashing via ISO/ICSP i would need to look up. No idea so far.


  • Developer of T2Laser Software

    Yes, you can use that Nano, they all have the same pin outs.



  • OK, that's what i did then now!
    I used the 3 axis boards nano.

    Will get a new one or check later on how to do the above mentioned flash.

    Now i am at the same point as before. Connected laser into the motor plug (2 pin connector) checked before with black and red from the 3 pin connector if the laser gives light. it does.

    But turning laser on via software does not work. The mill motor funny wise works.

    So i am back here for my laser connection problem.

    thank you guys so far. Hope somebody can help me to make my laser burn


  • Active Member

    Micc got this solves on another thread. His wires were reversed



  • Yes, thanks for summing it up here @nottingham82 .
    The laser connection topic is resolved by reversing the poles.

    Unfortunately now the laser does not turn off and does not react on the commands from the software. Still working on that.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.