Laser Always On Problem



  • Hi,
    I've searched the forum but have had no luck fixing this.

    I have the EleksLaser A3 5500mw (Mana SE board).

    Heres what I've tried:

    • Setup Benbox following these instructions: http://forum.eleksmaker.com/topic/25/benbox-instruction
    • Changed the laser setting from 12 to 11 in Benbox. Ticked the blue check button. The setting seems to be saved, closing the software and reopening it retains value 11.
    • Power up board and immediately the laser turns on full power.
    • I've also tried loading Grbl 1.1e from T2Laser and followed what Zax says to do to test the laser. Everything worked fine and I saw "Connected COM3 115200", "Gbrl 1.1e Ready"

    So I assume the laser is fine, but the value 12 to value 11 problem remains. Am I able to set that value in T2Laser as i'm able to control the XY Axis with manual arrows, but can't get the laser to turn off.

    cheers,
    Simon


  • Developer of T2Laser Software

    The Mana SE board is fixed to D11 for the laser control and my default Grbl 1.1e is also set to D11 so that means it should work.

    If your laser is still always on then you may have a faulty module. The simple way to test is connect the S-pin to GND (- pin). If the laser is still on then it's faulty. Make sure the software control is laser off before doing this test.



  • Ok, I'll try that. I haven't been able to get the pin out of the connector, but i'll try again later.

    So just to confirm, connect the S-pin on the laser to the GND (- pin) on the board with no other pins connected?

    thanks.


  • Developer of T2Laser Software

    @sbachell No, you just leave it all connected and powered so the laser is on (even though from software it is off) and put a short jumper wire down the connector to short S to - and the laser should turn off. That will tell you if it's responding to the TTL input or just on permanently.



  • It turns out there is a switch on the laser module to toggle PWM/TTL. I had checked for one before (as others in the forum had mention it), but it didn't look as I had expected. I've posted a picture below to show what it looks like as it may help someone else at some point.

    Also, the switch seems to only work when the laser has power to it. Not 100% sure of this, but I don't want to press it again now that its working correctly :)

    0_1499303722165_IMG_1189.jpg


  • Developer of T2Laser Software

    @sbachell Easy fix! :)


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.