eleks maker l1 with grbl or eleks cam laser always on



  • hello guys i bought the laser half year ago and when working with benbox it works fine but several times i tried to
    use grbl or other profi program when i load the hex and i change the pin to 0.9 the hex is sucesfuly loaded but
    when i turn on the power the laser is always on everything else is working fine but the laser is always burning
    and i dont know how to fix it and one week ago i find eleks cam and i trie it but the same the program load the
    hex and sucesful conect with the laser but when i turn on the power the laser is always burnig it burns the picture at
    the right size and the speed is changing when it sopous to burn and when its just traveling to another burn side but
    it always burns
    can please anyone help me


  • Developer of T2Laser Software

    Did you move the jumper under the Nano to the 0.9 position?

    0_1499373201921_L7_Board_nano.jpg

    0_1499373257987_jumper.jpg



  • yes i did


  • Developer of T2Laser Software

    @Powers If it works correctly with Benbox it should also work with other software, the MOSFET is what does the switching so if it has shorted the laser would be always on in any program. This happens if you leave the weak laser button pressed for too long.

    So confirm everything is working with Benbox still and then we can figure out why it doesn't work with other software.



  • yes when i move back the pin and load the hex with benbox the laser is working fine like it should have but if i change
    the pin back and go in elekscam the laser always burns when the power is turned on


  • Developer of T2Laser Software

    OK, so it should work using the correct firmware. EleksCAM requires the older Grbl 0.9, they provide mana.hex which is 0.9i. Is that what you're using?

    If you use T2Laser you can use Grbl 1.1 with 0.9 setting or you can try using the Grbl 1.1 non-PWM version in the custom firmware folder with the jumper set to 0.8. That will tell you if there's a problem with your hardware preventing D11 signal from working.



  • ok but where can i find the firmware hex when i installed elekscam the program select the Rst Rom the
    program load the 0,9i hex but i have the grbl v1.1e and grbl v1.1f and non of them is working always the same problem laser allways burns sa what can i do


  • Active Member

    This post is deleted!

  • Developer of T2Laser Software

    @mrmister Yes, try the default (standard) Grbl 1.1e in T2Laser which uses 0.9 position and if that doesn't work move the jumper back to 0.8 and try the Grbl 1.1e non-PWM (in the custom menu).



  • ok i try load the grbl 1.1e hex and with the program t2laser it doesnt work anything and an error apears and it say input string was not in a correct format than i load benbox hex with pin
    on 0.9 and the laser works with t2laser but it is still always burning and than i change the pin to 0.8 with benbox hex
    and the laser is working fine and not burning just when i want it to
    but when i try with grbl 3.6.1 i cant conect


  • Developer of T2Laser Software

    @Powers Are you sure the board is an Eleks L1? It should load firmware correctly with T2Laser if you have the port selected correctly.

    Yes, T2Laser does support Benbox hex and 0.8 but it would be better to use Grbl 1.1 non-PWM which is also 0.8 but newer firmware.



  • 0_1499536299890_IMG_20170708_194900.jpg
    is this the L1 or L7


  • Developer of T2Laser Software

    @Powers L7, which should work fine. Are you sure the correct COM port was selected when you tried to install firmware?



  • yes becauze it is always no com4


  • Developer of T2Laser Software

    You can use XLoader to install firmware if needed.

    It sounds like you have a fault with the Nano or board and D11 pin isn't working correctly.



  • maybe so what can i do?



  • and i knew about the xloader i use but i didnt find the problem so here i am


  • Developer of T2Laser Software

    @Powers I think your problem is the firmware isn't getting loaded, that would explain why the laser is always on when you move the jumper to 0.9 and you said it errors when flashing with T2Laser.

    Have you tried another USB cable?



  • no i didnt



  • hey guys thanks for yours help i dont knew what happens but it just start working when i change
    a few hex maybe the problem was realy in loading hex thanks a lot again


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.