Unable to upload firmware on A3 Pro 2500mW



  • Hello,

    I received my EleksLaser-A3 Pro 2500mW from Bangood and I mounted it.

    For the drivers and softwares I followed the installation tutorial from this forum but nothing works.
    I wanted to update the firmware of the EleksMaker Mana SE card but it is impossible to connect to it. The following error message appears briefly: avrdude stk500_getsync () not in sync resp = 0x00

    I tried the following softwares : EleksCAM, Benbox and T2 Laser but nothing happens.

    I also wanted to update the firmware with Xloader but every time the same response: Upload Failed.

    I also tried the update with EleksROM V3.8 but I have a libusb0.dll error that I can not resolve.

    Do you think my Mana SE card is out of order?

    Could you help me please?

    Thank you.

    Fabien


  • Developer of T2Laser Software

    Since you mentioned my software (T2Laser) and I know how to help you with it, click Help and Install CH340 Driver.

    Once that's complete, reboot and connect your laser.

    Then start T2Laser and go to the laser control screen, select the correct COM port from the dropdown and then click Upload Firmware (1.1e) in the Machine menu. If you don't know which COM port you can check Device Manager.

    If that works (no errors reported during firmware upload) you can connect to the machine by clicking the lightning bolt icon and test jog keys and laser control.


  • Active Member

    @wetete

    FIRST follow these STEPS before posting a question.

    DO NOT SUPPLY POWER TO YOUR LASER OR THE CONTROL BOARD UNTIL INSTRUCTED TO DO SO BELOW

    Change Regional Setting DECIMAL , to .

    Install Eleksmaker Cam software on your computer.

    Right click elekscam icon on deskstop, select PROPERTIES, select COMPATIBILITY, check the box Run this program as an administrator, click APPLY, click OK.

    Open elekscam.

    Plug the USB into the NANO.

    Plug USB into your computer.

    In elekscam click SETTING section
    6a. Install the DRIVER.
    6b. CLOSE elekscam.
    OPEN elekscam
    7a. In elekscam select COTROL
    7b. In COTROL select a PORT -DO NOT CLICK THE REFRESH SYMBOL, DO NOT CLICK THE REFRESH SYMBOL.
    7c. In elekscam selct SETTING
    7d. In SETTING click RST ROM - let the software run.
    After software installs CLOSE elekscam.
    Open elekscam.
    In CONTROL, look for PORT, select the appropriate COM port.
    PLUG IN THE POWER TO YOUR LASER.
    Your laser should now be ready for use.

    Issue: Laser is on at full power.
    Answers any of these may work:
    Did you supply power to the controller board without having elekscam open, if yes, turn off power to controller board; Open elekscam, power controller board.
    DO NOT turn on power controller board WITHOUT elekscam open.

    Issue: I installed benbox or T2 Laser, now elekscam does not work.
    Answer: Go to Step 7, reflash RST ROM.

    Issue: Red light on laser module is blinking.
    Answer: Blinking red light means "weak laser" is on, push the white button just next to the red light. OR use the weak laser button in elekscam

    Issue: Y axis not working
    Possible solution: Switch the Y axis cables on the controller board.

    Issue: Engravings are wobbly
    Possible solutions:
    Try reducing the feed rate OR
    Tighten or loosen the drive belts. (You will just have to figure out which)

    Issue: Elekscam will not open/load .svg files.
    Answer: Waiting on a solution from eleksmaker.

    Issue: Engraving did not start where I wanted it too.
    Answer: In CONTROL section of elekscam, use the x-,x+,y-,y+ to position laser to desired location; click SET ZERO (I also click HOME)

    Issue: I SET Zero and HOME, engraving still did not start where I wanted.
    Answer: In CONTROL section of elekscam, look for SET HOME COORDINATE, click any of the options to set the position of where you want laser to start.

    Other issues:
    Minimizing elekscam, cause elekscam to crash on my windows 7 pc.

    If all else fails:
    Banggood return policy



  • @Zax

    Hello Zax,

    I just try your answer but error is still there :

    0_1499645824453_Upload.jpg

    @mrmister

    your answer is exactly what I did when I started


  • Developer of T2Laser Software

    @wetete I would try another USB cable or remove the Nano from the board and see if it works then.



  • @Zax

    Nothing changes with another USB cable.

    What do you mean by "or remove the Nano from the board and see if it works then"?


  • Active Member

    @wetete

    WITHOUT power to the board, what color of light appears when you plug in the usb to the board and computer?

    With the usb plugged in to the board and computer, turn on the power to the board. What color of light shows pn the board.



  • @mrmister

    Without power : red and green

    With power : red and green and bleu on D4


  • Active Member

    he means to take the chip off the board. So the part you plug your usb plug into is called the nano and it is removable. Just grip either side of the pins and pull away from the board. Then plug the usb in and see if you get a different result. The nano doesnt know if its connected to the board or not so it will work unattached.



  • @nottingham82

    I tried but nothing changed. Always the same problems.

    0_1499695286398_20170710_155520.jpg



  • Do you think that the nano is out of order?


  • Active Member

    very well could be. I dont know where you are in the world. Here in california we have frys electronics which stocks them. Or there is always amazon. It is not a very expensive part. couple of bucks and its good to have spares.



  • I am in France. I just buy it to Banggood, I will contact them.
    Thanks.



  • @wetete I have same problem. You can solve it.

    1. Download EleksROM V3.8
    2. Download and Install !!! Bendbox !!! using this Instruction until "Firmware update" !!!
    3. Update firmware as Instruction says, BUT chose "mana.hex" from ...//EleksROM V3.8/firmware folder
    4. Open Eleksmaker CAM
    5. Chose your port. Refresh.
    6. Enjoy!

  • Active Member

    @Maxim-A said in Unable to upload firmware on A3 Pro 2500mW:

    @wetete I have same problem. You can solve it.

    1. Download EleksROM V3.8
    2. Download and Install !!! Bendbox !!! using this Instruction until "Firmware update" !!!
    3. Update firmware as Instruction says, BUT chose "mana.hex" from ...//EleksROM V3.8/firmware folder
    4. Open Eleksmaker CAM
    5. Chose your port. Refresh.
    6. Enjoy!

    Please remove references to Benbox.

    Elekscam and Benbox ARE NOT the same.

    Benbox is obsolete - it is no longer supported.

    Elekscam is installed and flashed, WITHOUT benbox.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.