2 Axis Move in Wrong Direction and Spindle Doesn't Spin



  • Hello, I have recently build my eleksmill and noticed that 2 axis move in the wrong direction and the spindle doesn't spin.

    I flashed the Mana controller using the Arduino IDE with grbl 1.1 (https://github.com/gnea/grbl) with the Arduino Uno board selected (I feel like the problem originates here, though I googled around and tried other boards with no avail as the file size was too big). I also installed GRBL controller Candle (newest version, https://github.com/Denvi/Candle).

    My +Y axis runs toward me (not away from me), my +Z axis moves down (not up), and when pushing the speed gear button, the spindle doesn't turn on (just makes a high frequency noise). Has anyone else run into this issue or have any suggestions for fixes (worst case is I can switch the leads on the two axes)?

    Thanks for your help in advance.



  • Very new to this, I figured out how to correct the axis traveling in the incorrect directions, simply change your $3 setting based on the following table...

    0_1501024989339_Flip_Axis.jpeg



  • Lastly, got the spindle to work. Assumed Candle was displaying speeds of 0 to 100 as percentage. If you increase the speed to 1000-10000, the spindle will work.


  • ElekMaker Develop Department

    yes,and you can try use elekscam to change the settings



  • I wish I could've tried out that software first, but I'm running linux and Mac. I believe elekscam is only for windows. The machine is up and running though so no complaints!


  • ElekMaker Develop Department

    i will try to write setting software for Mac OS


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.