2 Axis Move in Wrong Direction and Spindle Doesn't Spin



  • Hello, I have recently build my eleksmill and noticed that 2 axis move in the wrong direction and the spindle doesn't spin.

    I flashed the Mana controller using the Arduino IDE with grbl 1.1 (https://github.com/gnea/grbl) with the Arduino Uno board selected (I feel like the problem originates here, though I googled around and tried other boards with no avail as the file size was too big). I also installed GRBL controller Candle (newest version, https://github.com/Denvi/Candle).

    My +Y axis runs toward me (not away from me), my +Z axis moves down (not up), and when pushing the speed gear button, the spindle doesn't turn on (just makes a high frequency noise). Has anyone else run into this issue or have any suggestions for fixes (worst case is I can switch the leads on the two axes)?

    Thanks for your help in advance.



  • Very new to this, I figured out how to correct the axis traveling in the incorrect directions, simply change your $3 setting based on the following table...

    0_1501024989339_Flip_Axis.jpeg



  • Lastly, got the spindle to work. Assumed Candle was displaying speeds of 0 to 100 as percentage. If you increase the speed to 1000-10000, the spindle will work.


  • ElekMaker Develop Department

    yes,and you can try use elekscam to change the settings



  • I wish I could've tried out that software first, but I'm running linux and Mac. I believe elekscam is only for windows. The machine is up and running though so no complaints!


  • ElekMaker Develop Department

    i will try to write setting software for Mac OS



  • @nickolas said
    simply change your $3 setting based on the following table...

    Forgive my ignorance but I too am having trouble with the Z axis going the wrong way. I have spent a couple of days trying to find a file with $3 in it but have so far failed. Can you elaborate on where and how you change "your $3 setting"...
    I am using Candle to run the mill for engraving. Thanks...


  • Developer of T2Laser Software

    @DCJones You need to send a manual G-code command to the firmware, which would be something like $3=x where x is the value that corresponds to the axis directions (see the chart above).

    If you are having problems sending the commands, and the software doesn't have a simple way to reverse the axis you could use my software T2Laser to change the parameters. It can be done in the menu, just a click and it changes the Grbl parameters for you, then you can go back to using whatever you want to run the machine.



  • @Zax Thanks for the reply. I did figure it out, finding that you have to use something like putty to log into the board. From there using the $$ command to change the parameters went smoothly. I assume you can't do it through Candle which is what I was originally doing.
    Good to know that your software is there as an alternative...


  • Developer of T2Laser Software

    @DCJones In T2Laser it's easy, just click the Reverse Axis options in the Settings menu, you don't need to use any other software or understand the $ commands. I try to make it easy for users with T2Laser.



  • @DCJones Sorry, I've been away for a little. You can directly alter these settings in candle. I have attached a generic screenshot of Candle from the github page. In the bottom right corner, you can see a little typing interface with the paper airplane beside it. Type the command you want to send here and push the paper airplane icon for sending.

    0_1505082647867_screenshot.png


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.