Laser not turning off



  • Hi I have a A3 laser with the EleksMana SE to control it and a 15 watt laser module on its own power supply.
    All is working correctly except for the laser turns on as soon as the power is connected to it, the laser is connected via just the ttl line and the negative line to check the laser unit I shorted out the ttl line and the negative line at the output from the board and the laser turned off as it should so all the wiring is correct.
    Is there any easy way of checking the output from the board?


  • Developer of T2Laser Software

    Disconnect the laser and use a multimeter (DC volt meter) to measure the TTL signal, it's a (PWM) switched 5VDC so when the laser is at full power it will read 5V and when off 0V, then you'll see what appears to be an analog signal between 0 and 5V with different power levels.



  • @Zax
    the pwm signal line stays around 2.5 volt no matter what i try to set the laser at in the program, I do not have a scope to see what the PWM signal doing, if I could get a copy of the file that the arduino is using then I could figure it out most likely the program uses a pwm signal and not a ttl and I bet it is only a couple of lines of code that needs changing a arduino can output both TTL and PWM but unless I can get a copy of the program i have no idea what it would be.

    regards Poppy Ann


  • Developer of T2Laser Software

    @Poppy-Ann The output on D11 (same as the S-pin on the Mana SE board) is a PWM signal at TTL levels, meaning it's 5VDC that is pulsed on and off at a given frequency, in this case either ~1kHz or 7.8Khz depending on the firmware.

    The "motor" output is a PWM signal at 12VDC, this comes from the MOSFET on the board, it's gate is driven by D11 also.

    You can download the Grbl source from github.



  • @Zax Hi Zax I broke down and bought a Oscilloscope so I can read the signal line it does not change whether the board is set to laser on or laser off or at least not more than a couple of millivolts and the waveform stays the same I even tried changing the setting for the laser by moving the slider on the settings tab just in case it was too high.

    I have ordered a new board and will check to see if that is any different I have been looking for the uncompiled code for the board just so I can check if there is a software problem I have the .hex file but that is already compiled and I cannot read it in that format.
    I will keep at it I even tried a PWM to analog converter board to see if that would sort it out but that was the same and did not change the output whether the laser was on or off.

    thanks for your help
    Regards Poppy Ann.


  • Developer of T2Laser Software

    @Poppy-Ann You can download the source code from Github https://github.com/grbl/grbl (the Eleks hex is the older 0.9 version).

    The Nano microcontroller is what generates the PWM signal, so either it is faulty or the board has a short. These Chinese boards use a Nano clone, with copies of the original chipsets that are supposed to work the same. I have found them to be much less reliable than the original Atmel and FTDI chipset. If the MOSFET is bad it could be pulling the pin down.

    I wouldn't worry about finding the cause too much, the Nano clones are $2 and the board with drivers ~$20.



  • @Zax I am sure the main board is faulty I stuck it on the scope and all i get is interference but no main signal I tried the scope on a servo tester and it shows the square wave signal great and shows it change as it should when you move the control knob I have been busy and not had more than a few minutes to try sorting it out but once the new board arrives I will stick it straight onto the scope and see what sort of signal it puts out.

    It is not the Hex code i wanted but the un compiled code so I can read it, it is a long time since I use to play around with reading hex code and I think I have forgot around 95% of what I use to know and back then I was not the best programer of hex now a days I would have to have a look up sheet to try finding what each hex code does, you have next to your name developer of T2 laser software is the T2 much better than Eleks or benbox I am new to all of these stepper motor drivers and have no idea which is meant to be the easiest to use I am only playing around with it it is not for any sort of business I just like to dabble I have built a cnc mill that is running Mach3 software but it needs a small mod as the frame bends slightly so it runs out of line a little then jumps back but that was when I was milling some 4 mm aluminium angle to make a bracket for the laser unit to fit the frame as the 15W laser is slightly larger than the holder.

    thanks for your help,
    Regards Poppy Ann.


  • Developer of T2Laser Software

    @Poppy-Ann Of course T2Laser is better :)

    The github is the source code, not the compiled hex.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.