EleksLaser A3 Pro Laser is always burning



  • Hi, my Laser arrived me since 3 days and i have no idea what i can do to got running it.
    All axis running perfekt, i also can simulate burning. Only the laser would not work.
    Immediately after I turn on the mana se board the laser begins with full force the burning process. also the fan blows immediately after switching on.

    Can anybody help me?

    Here is a Video which shows my problem. https://youtu.be/4L6OXkGdKkY



  • @hauzi2k17
    Ηι,
    When the Laser starts operating, it always burns for two seconds. It's a circuit problem. In the video you turn it off immediately and it does not seem to work permanently or if it's just the problem I mentioned above.
    For more information
    http://forum.eleksmaker.com/topic/733/t2-laser-strong-laser-point-after-clicking-control-laser



  • @nikolinos thx. i've took another video of my problem Youtube Video



  • @hauzi2k17
    Α common problem.
    Search: "Laser always on"



  • today i've tried to connect the laser with the 2 pin motor port on mana se. now the laser works. not perfekt but works.
    my laser board have a 3 pin port but no switch for ttl/pw. i only connect 12v - and ground to motor port on my mana se.
    i can use the laser now, but i think that's not the right way. i can engrave lines but if i try to burn dots/points i think the impulse to start the laser need too much time. i must turn the ms over 400 to burn a dot.

    someone have an idea?



  • @hauzi2k17

    My idea is you give power to laser when laser NOT plugged into computer and laser software NOT running.

    Do not turn on power to laser if you not have control board connected to computer and you have laser software on.



  • @hauzi2k17

    I watch orher video. You not have stepper motor problem. You probably have design problem with plastic plates on X axis.

    Loosen belt first. If that not fix problem you wheels tight. Make holes for wheels larger like ovals that are 90 degrees to horizontal plane.



  • @Anatoly thx. this problem i could resolve by myselfe. problem was the plastic distance holders :)


  • Active Member

    @hauzi2k17 that of course works but you will have less control over laser power. In my opinion it is not worth the trade off I'd rather just reach behind and turn the power off when connecting have good power control



  • @nottingham82 thx. you're right. but with the 3 pin cable it would not work. i have tried really all options i've read in forums :(

    my connection with 3 pin cable looks S -> PWM GND -> GND and + -> VOC of Laser module. There is no Jumper on my fake arduino nano and no ttl switch on my laser module. i've only the low power button on my laser.



  • I´ve taken 3 new videos which should show my problem. I hope somebody can help me...

    Here my main Problem with original connection
    Youtube Video

    Here a try to connect with motor port
    Youtube Video

    Here my main problem with connection with motor port
    Youtube Video

    best regards
    Martin :(



  • Here another video. I´ve tested the connection (board/laser) without the "arduino nano". So can not be the software? Or is that ok?
    Youtube Video


  • Active Member

    That shouldnt be possible. The laser should need a 5 v signal from d11 to turn on. So there is something wrong with your laser control board. The board that is physically attached to the laser. To be sure use a multimeter on the s pin. It should read 0 volts. Then take a look at your laser and look for something that appears broken, cracked, or soldered wrong.



  • @hauzi2k17

    I believe you not have problem with laser or problem with control board. You have problem with how you operate laser and software.

    You power laser without connect laser control board to computer and without laser control software on. Make new video show you have 3 wire connected to laser and connected to control board and show not have power turned ON and show you have laser control board connected to computer and show you have laser control software ON and then show you power on laser control board. I bet you not have laser problem if you follow step I give.

    Other problem, you must operate elekscam software as
    "RUN AS ADMINISTRATOR" for functions to work.
    Other problem, you try to make 20 lines per mm, that a reason why you get error. You need to not try to make more than 6 lines per mm.


  • Active Member

    @Anatoly it can't be a software problem with the nano disconnected. The laser should be off. The fact that it's not shows it not a firmware or software issue.



  • @nottingham82 said in EleksLaser A3 Pro Laser is always burning:

    @Anatoly it can't be a software problem with the nano disconnected. The laser should be off. The fact that it's not shows it not a firmware or software issue.

    . hauzi2k17 control board is good, laser is good.

    @hauzi2k17 not have problem with laser or board. He have problem by not operating laser and software correctly.

    Hauzi2k17 mistake is Usb cable from nano to computer must be plug in at computer and nano BEFORE turn on power. hauzi2k17 turn on power and not have cable plug in usb to nano and computer.

    hauzi2k17 follow my steps from other post and you not have any more problem.



  • @nottingham82

    thx for help. here a video with voltage check. look like the board is ok?
    Youtube Video



  • @nottingham82

    another try.... if i connect laser with motor controll on board i could turn on/off the laser. i also checked the voltage and i could not understand this.
    with voltage meter i got 12-13v on this port. also when i turned off the "laser" with software. in the video i'll show when i connect laser this is switching off? but voltmeter shows petmanently 12v. is that right so? but how this works with laser? :)
    Youtube Video



  • @nottingham82

    My brother told me to check the resistance between the pins.

    Here you can see the resistance between GND --> VCC
    0_1506241675771_GND_VCC.jpg

    And here you can see the resistance between PWM --> GND. Is that ok so? My brother is not sure, but he think ther should be a resistance between PWN and GND.
    0_1506241800329_PMW_GND.jpg

    Is that ok? Or could it be a Short to ground? I don´t know the english word for connecting + - . We say "Kurzschluss" or "Masseschluss".

    best regards and thx
    Martin


  • Active Member

    Your board is working perfectly. So is your software. It should give off a steady 12 v on the + and should give 5 volt when the on button is pressed. And that is what you showed is happening. What isn't working is the laser controller. When the 5 volt is off the laser should be off. If you can afford it I would replace the laser. It is definitely the problem. However you can try to fix the little controller on top of it but I don't know much about fixing those. A new 2.3 watt laser is about $70 on banggood. Depending on what distributor sold you the machine you may be able to get them to pay for it to send you a new laser.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.