Stepper stuttering when connected to PC



  • Hey everyone,
    I just got and assembled my EleksLaser A3 Pro, but when I connect it to my PC the stepper motors begin to stutter and slowly move along the axis. It doesent matter if I have a control Software running or not.
    This only happens when connected to a PC. Powered with only the powersupply they stand still...
    When connected to the PC I am able to send commands to the machine and move it, but I'm not able to stop the slow stuttering movement of the steppers.
    I already checked the voltage/current of the stepper drivers....

    Anyone got an idea what's happening or a similar problem?


  • Active Member

    Have you tried reflashing the firmware?



  • Hey,
    thanks for your fast reply and sorry for my late reply!

    As it turns out it really was the fault of the firmware. Apparently I had a faulty version of the Benbox firmware. With this version reflashing the microcontroller didn't change anything. After that I tried a diffrent firmware which resolved the issue. An now I even found a working version of the Benbox firmware!

    Thanks for the help!

    Next step is going to be figuring out how to get a servo working with Benbox. Wish me luck ;)


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.