L Cheapo 8W/Mana SE issue



  • Backstory: I bought a cheap chinese laser engraver off ebay. Similar to EleksMaker, but different motherboard, has one Laser 12v/5v 2wire port. I bought an L Cheapo 8w, wired it up, accidentally fried the motherboard and nano chip. Wound up buying an EleksMaker Mana SE since it is an equivalent board to what I was running.

    0_1507234283384_20170928_184419.jpg

    Anyhow I got my Mana SE board and am having issues with the L Cheapo, the laser only has a positive and negative wire, I can also run a PWM wire to it, but haven't yet.

    The issue I have is that once I hook power into it and hit the power on button the laser stays on full blast and won't turn off or vary power. This is when I have the laser plugged into the "Laser" spot on the motherboard. I tried using T2 Laser to override it as well as use the M commands to turn off the laser, nothing worked. I also tried plugging the laser into the servo port as I'd seen other lasers plugged there and the laser just remains very dim and won't fire. I also tried the motor port (as I read in another thread) and the laser was a little dim while at rest and fired where it should, however it didn't fire full power like how I had it set (this is exactly how the laser acted in my original board, very under-powered and the original .5w laser I had did a better job). Also on the original motherboard when I had the PWM wired in the laser wouldn't turn off so I had to disconnect the PWM wire and run in dither mode instead of grayscale.

    I thought this might have been a firmware issue. I had grbl 1.1f on it initially, then reverted to 0.9j, still happens no matter what version I use.

    Any ideas of what is wrong or what I'm doing wrong? Is this a setting in the firmware or do I have the laser plugged in at the wrong port? Does it need a PWM wire ran to counteract it being on?

    Thanks.


  • Developer of T2Laser Software

    @TPP1776 You do need to use the motor connector as your laser doesn't appear to have TTL input. So when you did that, what firmware and laser power did you use?

    I'm wondering if you had already changed to 0.9 and should have used 1000 for laser power?



  • @Zax I think I had already reverted back to the .9 version by the time I plugged it in the correct slot. Didn't know 1000 was max power since default is 255, I thought 255 was max (n00b mistake). Is 1000 also the max power for version 1.1f as well?

    Also for the PWM I just need to solder it to the D11 pin on the nano correct?


  • Developer of T2Laser Software

    @TPP1776 All of my firmware is compiled to use 255 as that is the capability of the Nano PWM output (8-bit) but Eleks use 1000.

    You can easily change it using a Grbl parameter, but anything higher that 255 has to be down scaled so it really doesn't make any sense.



  • @Zax So you're saying with this new setup (Mana SE) 255 is only about quarter power?


  • Developer of T2Laser Software

    @TPP1776 If you use the EleksMaker firmware and do not change any parameters, that is correct. Using default Grbl or any of my firmware it will give you full power. Mana SE is the board, it can work with any firmware.



  • @Zax The version of grbl I put on last was the 0.9i EleksMaker version you have built into your T2Laser program. Would there be any good reason for me to upgrade the firmware to 1.1F?


  • Developer of T2Laser Software

    @TPP1776 Yes, 1.1 has many improvements. It provides faster and smoother motion control, real time overrides and dynamic laser power. There are other things too, but those features are enough for me to recommend it.

    The only reason to use the older 0.9 is if you have a CoreXY machine as compiling 1.1 to fit on a Nano is a challenge.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.