A5 2500W Port is denied (Axis Not Working)



  • Dear readers,

    I have recently bought the A5 2500 W laser engraver.
    I assembled it according to the assembly instructions by Banggood.
    When I connect the USB to my computer I see a green light with directly above it a red light. It is in the mini USB section of the motherboard.
    Then I start the Eleksmakr program and it connects with the COM port my laser is on. I can start the laser through the program but when I try to move the axis it instantly pop-ups a message in Eleksmakr that the connection to the COM port is denied.

    I have tried it on many computers now, and all give the same error.

    This is what the error says:
    ************** Exception Text **************
    System.UnauthorizedAccessException: Access to the port 'COM4' is denied.
    at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
    at System.IO.Ports.SerialStream..ctor(String portName, Int32 baudRate, Parity parity, Int32 dataBits, StopBits stopBits, Int32 readTimeout, Int32 writeTimeout, Handshake handshake, Boolean dtrEnable, Boolean rtsEnable, Boolean discardNull, Byte parityReplace)
    at System.IO.Ports.SerialPort.Open()
    at SwitchMachine.Form1.OpenPort()
    at SwitchMachine.Form1.dSkinButton1_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at DSkin.Controls.DSkinButton.YlpFYcQM82FqWMGF46bp(Object , Object )
    at DSkin.Controls.DSkinButton.OnClick(EventArgs e)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1076.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll

    SwitchMachine
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/EleksMaker/EleksCAM/SwitchMachine.exe

    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1075.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1068.2 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

    DSkin
    Assembly Version: 16.4.1.7
    Win32 Version: 16.4.1.7
    CodeBase: file:///C:/Program%20Files%20(x86)/EleksMaker/EleksCAM/DSkin.DLL

    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.81.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.



  • One suggestion that I am sure you have already tried

    Reboot your computer

    Also, uninstall the software AND DRIVERS and reinstall



  • UPDATE I just got it working.
    Somehow the usb connector did not connect well so I put it in the connector halfway. Then I selected the Laser Engraver in Elekscam. And clicked on the Rst ROM button. After that it works perfectly fine now.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.