Laser turns on by itself?? A3 2500mw MANA SE



  • I've just built and trying out the EleksMaker A3 and the laser is turning itself on every few seconds ruining the engraving before its even started. What grbl/firmware should I be running? Not having much luck with updating the firmware with EleksROM. I get an error :
    'avrdude.exe - System Error
    The program can't start because libusb0.dll is missing from your computer.'

    Hope someone can help.

    Thanks

    Chris


  • ElekMaker Develop Department

    Hi,
    0_1490319752969_QQ截图20170324094218.jpg



  • @EleksMaker-Z I found the file in the EleksCAM directory like @alpard78 mentioned. Managed to uploaded firmware without getting any error message. But I still get laser turning its self on.

    Youtube Video

    Thanks



  • Has anyone else had a similar problem?


  • Active Member

    This post is deleted!


  • @mrmister I'm not powering the laser before. You can see in the video above. The board is connected and the software is open. I then push the button on controller to power up the machine. Before I can generate gcode the laser pulses on for a few seconds. The program will run correctly ( engraving as expected ) but if the board isn't switch off immediately once completed it will continue to pulse the laser on randomly. I haven't seen any other threads with this problem. It does the same in T2.
    Thanks


  • Developer of T2Laser Software

    It sounds like the wrong firmware, but if you connect only power to the laser does it still randomly pulse? In other words, disconnect the S pin from the connector and on the laser side connect it to ground.



  • @Zax Thanks for the reply. Sorry, I'm not sure what you mean by disconnect the S pin.

    I've installed Benbox updated the suitable firmware for that and it works in the respect that the laser won't unexpectedly turn on, but I don't want to use Benbox as the reviews are terrible.


  • Developer of T2Laser Software

    In Benbox, what pin are you using for the laser? (D11 or D12)



  • @Zax My Benbox settings are shown here. 0_1490889283383_upload-0ad69581-c9f5-4e5f-b164-8f5a65064758


  • Developer of T2Laser Software

    It is using D11 so should work correctly with other firmware and software. I have never heard of this issue, perhaps a problem with the Nano but I don't know why it works with Benbox.



  • @Zax I read on another thread a faulty MOSFET could cause the laser to switch on? I'm not sure what this means but could it be this?


  • Developer of T2Laser Software

    From your video the laser is plugged into the 3-pin laser connector, if so, that does not use the MOSFET. That is switching the 2-pin motor connector which is what you would use with the older non-TTL laser modules.



  • I'm at a loss with what I can do about this. I've contacted the retailer (Banggood) and they've given me links to EleksCAM & Benbox which I've installed both. I found the new download link for EleksCAM to give the same results as the video shows (T2Laser does the same thing). BenBox works but is awful to use and doesn't produce engravings as well as the EleksCAM program. Really disappointed, as the kit could be really good if it worked.


  • Developer of T2Laser Software

    In T2Laser if you click the manual laser OFF icon, does it still randomly come on afterwards? If so, it sounds like the PWM output from the Nano is getting some noise. You could probably fix it easily by adding a pull down resistor. There's explanation on this at another forum but I don't think I am allowed to post a link.


  • Active Member

    This post is deleted!


  • @Zax Thanks again for the suggestions. I'll try this later on. I'll try and hunt down this thread too. I can literally hear a noise when the laser turns its self on, I think its coming from the board?????

    @mrmister I know, they're just the retailer but I'm ALMOST convinced its a faulty board (hence why I contacted them). I've reflashed the controller to the appropriate firmware for EleksCam, and tried the available grbl variations in T2Laser with the same result. The real head scratcher is that its ok in BenBox. Baffled!!!!



  • @ElekMaker-Develop-Department @EleksMaker-Z Could you suggest anything to fix this?



  • Could there be a fault on the circuit board thats on top of the laser module? Can anybody help please???
    Also, I've got another laser module on the way to try and I've just realised its not got this board on the laser. Can I still use this?

    @Zax @mrmister @eleksmaker-z


  • Developer of T2Laser Software

    @chriscassin since it is working with Benbox, the board must be OK. The only difference is Benbox firmware doesn't support PWM so you only get on or off command to the laser. The PWM signal is coming directly from the Nano clone to the laser driver and the Mana SE board does nothing.


Log in to reply
 

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.