@Nistorescu-Alexandru What do you have the rapid feed rate set to? Set that to 3000 and see if it helps.

My default max is 5000 mm/min, which should be more than enough but can be increased if your machine is capable.

You should also set Frame Rapid Feed to enabled, otherwise it will use the vector feed rate.