Z probe on EleksMill

  • Has anyone successfully incorporated a Z Probe for mapping a PCB on the EleksMill?
    I note the Mana controller has a contact on the yellow interface connector labeled PROBE.
    Any assistance and direction would be appreciated.
    Thanks in advance.

  • Active Member

    this is what github says about using grbl for a probe

    $6 - Probe pin invert, boolean
    By default, the probe pin is held normally-high with the Arduino's internal pull-up resistor. When the probe pin is low, Grbl interprets this as triggered. For the opposite behavior, just invert the probe pin by typing $6=1. Disable with $6=0. You may need a power cycle to load the change.

    NOTE: If you invert your probe pin, you will need an external pull-down resistor wired in to the probe pin to prevent overloading it with current and frying it.

    Dont know if that helps

  • @nottingham82
    Thanks for your response.
    I analysed the PR port of the Mana controller and found it had an open circuit voltage of 4.7V with a 35K pull up resistor, so concluded it would be safe to connect the PR terminal to ground.
    As a result, I connected the Ground pin on the Mana connector to the milling tool, and the PR contact to the PCB.
    I set up the height map in Candle to the size of the board to be milled and started the probe.
    The probe and mill proceeded exactly as I would expect, transversing the board according to the grid I had defined.
    However, the results were not as I expected.
    The board dimensions I input to the height map were in mm, and the red boundary of the test area shown in Candle for those dimensions, were coincident with the board outline. I assume then, that the measurements entered by Candle into the height map table in Candle would also be in mm's.
    The results in the height map table indicated a worst case error of 5.9mm, which is clearly, not the case.
    Furthermore, the visualisation of the board shape in Candle was the opposite to what it actually was.
    Needless to say, the attempt to mill the board with that height map correction was a total disaster.
    Any idea what I have done incorrectly?

  • Active Member

    @Nomads1 you already know more about it than I do :) I dont even have an eleksmill and a probe wouldnt help me on an eleks laser. If you get it figured out let us know what you changed.

  • Hello,

    I found port description for mana controller : https://www.banggood.com/fr/3-Axis-Stepper-Motor-Driver-Board-Controller-Laser-board-For-DIY-Laser-Engraver-p-1015947.html?cur_warehouse=UK

    this week i would try to examine this port and make a probe with a pull-up resistor (10k).
    it is necessary to make quality PCBs.

    Have a good day

  • @Petardfrancois
    Thank you Petardfrancois for your response.
    I had seen that page. It is the one that pointed out to me the probe contacts on the Mana board.
    I don't believe the probe needs to incorporate a pull up resistor, that is on the Mana board.
    I am now investigating the height probe application in OpenCNCPilot, which seems to be working better than the one in Candle, though I do have some questions about it and hoping for clarification from users on the site.
    Good luck with your endeavors.

  • Hello,

    OpenCNCpilot : https://www.youtube.com/watch?v=XDCu3cgOjCY&t=43s

    I want try this software ^^ !! it's the solution for planemetrie mistake on PCB board !

    I found this schema : https://www.autoleveller.co.uk/cnc-probe-guide/


  • @Petardfrancois
    That link you include is the one which led me to look at OpenCNCPilot.
    I have done several runs with it now, but sadly, the results have not been an successful as I had hoped.
    I have some issues with the height map data, which another user also reported.
    He found a solution, but I don't understand what he did to solve it. I have asked for clarification, but no response has been received so far.
    I still think it is the solution I am looking for. I quite likely have some setup error.
    Please keep in contact with your results.

  • Hello,

    I do my first test with probe Z function, and work ! :)
    With a very low-cost PCB ^^
    Just switch drill an PCB with 0v and PR pin...
    GRBL $6 = 0.

    Youtube Video

    But, i have a trouble message on OpenCNCpilot console, maybe it's normal... i don't know.. next : engraving test !

    Have a good day

  • @Nomads1

    i try to engraving a simple circuit without verification, just software measured and the circuit test.

    For the moment, i don't know if the software send false mesure

  • Hello,

    I try surface probe on Candle and it work more better than OpenCNCpilot (on OpenCNCpilot, it's bugged for me) !
    I made a test on PCB with a small circuit and the result it fine, i engraving with depth (z) 0.05mm, i think would i have more better result at 0.04 (my PCB copper thickness is 35µm (0.035mm)).


  • Hello,

    finally, i use probe Z grid with Candle (work only with grbl 0.9) and it's very fine !!

    For my PCB project : Proteus + FlatCam + Candle with probe Z (one square by cm² for grid)

    GRBL: 0.9j

    Tool : the original drill engraving shipped with your eleksmill :)

    Proteus config PCB:
    trace style T15
    clearance 15th

    FlatCam config:
    Cut Z : -0.06
    Feed rate : 150

    Candle area probe Z config :
    One probe each per cm² and don't forget to apply on your project.obj !

    Probe connect on Mana Controller :
    Ov and PR pin (GRBL $6 = 0.)


    PCB Result :


    Bye :)

  • @Petardfrancois
    Congratulations with your efforts. I think you have achieved excellent results.
    Successfully milling a board with 0.06mm isolation depth is, I think, a great achievement.
    I have managed to mill a board, and I thought I had done well, but now, having seen you results, I am convinced I still have issues with the Z probe. My milling depth had to be set to 0.22mm before I could achieve a repeatable, successful result, 0.18mm didn't succeed. When I milled my board the Z axis stepper was moving, though only very slightly, but seemingly, not enough.
    Perhaps I go back and re-try Candle.
    You indicate that you are using grbl 0.9j. I am using grbl 1.1f. Have you seen anything which would indicate the 1.1 version of grbl with Candle might be an issue? Should I go to grbl 0.9?
    I note from the picture of your board you do not seem to be using the remaining copper of the board as the ground return line. Any reason why you haven't done that? This process reduces the tracks on the board, potentially making the routing of other tracks simpler, and the method improves ground paths, reducing ground loops and improving shielding of signal lines. It also reduces the amount of milling needed, hence less tool wear, and faster production, though time probably isn't a major factor.
    Again, well done. I'll just keep trying.

  • @Petardfrancois
    I installed grbl 0.9j on my mill and tried Candle again. Same results. The Z probe results are totally unbelievable, the plot looks like the side of a mountain, and the figures in the height map range from less than one, to 5's and 6's. I am assuming those figures are mm's. What am I doing wrong?????
    I would be interested to see a height plot generated by your system. Would you consider communicating direct by email and comparing plots?
    While I had grbl 0.9 installed I tried OpenCNC. As indicated on the OpenCNC site, it would not work. It needs grbl 1.1. Perhaps that was your problem with it?

  • Hello,

    When i probe the surface on my PCB, the values range from 0.00 to 0.4 mm (my CNC support leans a little... )

    1 : Place the drill at start (manual)
    2 : Reset coordonate X and Y axis
    3 : Probe the 0.00 surface (in control menu)
    4 : Reset Z position
    5 : Load your .OBJ pcb
    6 : "create heightmap"
    7 : Configure and launch....

    I will post a "map probe " picture from Candle... (i found this https://www.youtube.com/watch?v=tK5Amg-Ye58)

    I have a little problem with Y or X axis (backlash ?), i have a little deformation, look on my PCB picture, the horizontals trace look are like wave...
    For the ground return line... i forgot to do it ^^


  • @Petardfrancois
    Hi Chris,
    thanks for coming back on this.
    That video is interesting. I hadn't seen it before.
    Interesting that the user makes NO attempt to zero any axes before he starts the probe cycle.
    He loads the board file.
    Selects "Height Map", then selects "Create".
    He has "Auto Border" set, so doesn't have to input the probing area.
    He then selects "Probe".
    He has not zero'd any axes.
    Work Cord for Z is 5.000 and the Machine Cord for Z is -5.500 when he starts the probe run.
    The machine then probes X/Y zero and moves to the bottom LH corner of the board.
    Interesting that the orange probe symbol is visible moving over the whole board, as the plot progresses.
    In my case, the probe vanishes off the LH side of the screen. If I zoom out, the probe would be shown some 20 board widths off to the left, and as the probe cycle progresses, the magnification is also present in the Y direction. At zero X and Y, the probe is shown at X/Y Zero on the board, then when the probe moves to the next positive Y position, the orange probe symbol disappears off the top of the screen. Just another issue I am having with Candle.
    When his probe measurements become visible in the table, you can see that the figures recorded in the table do not correspond with any Z readings in the Machine or Work Co-ord windows. The first three rows that we see recorded in the table all show positive values recorded, but the values shown in the Work Co-ord Z window are all negative.
    I guess what this is all saying is that Candle does not calculate the board deviation relative to our starting Zero that we have been so careful to set, but from the first zero point taken at the start of the probe cycle, which it doesn't display. Strange!!!
    The results he records seem quite believable.
    Break in proceedings.
    Well, after some more head scratching, and a break away from the CNC for a while, I decided to download Candle from the Webb again. (Still don't know what made me do it, but I'm sure glad I did.)
    The copy I have been running I got from the EleksMaker site, but since downloading it, I found the GitHub site for Candle.
    I decided to download that one, despite it being reported as the same version, and same size.
    I am very pleased to say all my Candle problems now seem to have been solved. Yippeeeee!!!!
    On the height probe using this new version, originating at the same place on the blank board as I have done my last probe tests, the maximum error was 0.317mm, and the lowest figure was 0.002mm at the X/Y origin :). Those results I feel very comfortable with. The last probe run I did with my original Candle program had a maximum error of 8.53 and minimum of -0.051.
    I haven't milled the board yet with this version, I'm hoping my elation isn't premature.
    By the way, I noted that Candle 1.1.7 is for grbl v1.1, and for grbl v0.9, Candle 1.0 must be used. Don't know if that affects you.
    I'll let you know the results of the next PCB mill.
    You can email me directly at sedgmanr(at)yahoo.com

  • Hello Ray !

    I am happy to know that your problems are solved with CANDLE and the probe function.
    I have the 1.0.11 CANDLE version, I'm going to try your version (1.1.7) with grbl v1.1 next week.
    Since I'm doing tests PCB with CANDLE probe and FlatCam, i have (for the moment) 0% of fail XD, this machine is really perfect for that !!
    i've allway this imperfection (wave effect <0.1mm) on Y axis, but not very annoying for my future projects.

    I disassembled and remade all the tray Y, I reduced (a little) the wave effect and I almost removed the inclination of the tray.
    I think:

    • It's a bearing with a wrong adjust or with a machining mistake (all axe on my machine are not perfect smoothing).
    • A deformed guide shaft.

    I think, i going to open a new topic for this, but it's not really annoying....



  • @Petardfrancois
    Hi Chris,
    I have now produced a PCB with 0.06mm isolation depth. It looks excellent. I am very pleased with that result.
    Unfortunately, the drilling of the board was not successful. For some reason I could not return the mill to X/Y zero, so a manual re-positioning was done, but the registration was not good and the drill holes were off. My work so far is on trial PCB's, I'm still learning the ropes with the machine, so nothing lost.
    The solution I used for the table trueness was to screw a piece of 10mm MDF board onto the table with countersunk screws, then mill the top of the board flat with the machine. I screw the PCB to the MDF top with small screws, as well as placing double sided tape between the PCB and the table top. I still find the PCB has flex when the tool touches the PCB, so the double sided tape solves that.
    A wooden table top has another advantage in that when you drill or mill the PCB, you don't cut into the metal table. When the top eventually becomes untidy, just replace it with a new board and mill it flat again. Back to new again.
    I also see a small wave in some of my Y plane lines, but I couldn't attribute that to the table rails, the wave period is to short.
    My immediate task now is to sort out the drilling, then to mill the PCB out of the board blank.
    I've run out of Isolation bits now, so I will be taking a short break from the mill and do some other things 'till the replacement bits arrive.
    Happy New Year to you.

  • Happy new year Ray,

    I made a special support (epoxy) for made double sided PCB.... i will try this next week and i post the result.


  • Hi boys,

    I'm using same HW configuration as Petardfrancois,
    Then Altium for design, FlatCam (Cut Z: -0.05, Feed rate: 40) and OpenCNCPilot for machining.

    In this design I used 0.4mm - 0.15mm lines
    here is my result:


    Size of the design is 30x26mm, there are two designs milled.
    Only 0.15mm lines are not good, 0.2mm lines are OK but I think this result for the price of EleksMill is cool.
    Thanks EleksMaker...


Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.