Drawings are diagonal (rotated 45 degrees)

  • I'm still troubleshooting my Eleksdraw - It's connecting to the computer OK and I can get it to move about - servo is not lifting the pen, but I see there is an update for that.

    Testing it with the pen just dragging on the paper, all my drawings are rotated by 45 degrees from the X/Y axis of the machine. Is there a way to adjust for that?

  • Developer of T2Laser Software

    Most likely you have the wrong firmware installed, the EleksDraw is a CoreXY plotter so needs the appropriate firmware.

  • I'm using the firmware that was supplied with the device (which was advertised as fully assembled and tested, but turned out to be a kit and I still can't get it working)

    I tried updating the firmware using the instructions in another thread on this forum - I'm not sure if it worked or not - I got an error saying Libusb0.dll is missing, but it still appeared to download something.

  • Ah! I found LIbUSB on Sourceforge and installed that - and the firmware is updated - now it's working correctly (except the servo, which I think is a completely different problem)

  • @Atomic-Shrimp
    For EleksDraw what was the latest firmware you installed and from where did you get it? I have the same problem with diagonal printing.

  • Developer of T2Laser Software

    Use the mana.hex and send the appropriate commands for you system.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.