Servo makes ratcheting sound but does not move

  • @EleksMaker-Z Tried both of these. Manually push the servo down so it's not jammed against the end stop. Restart everything. Search for port and select. Set EleksDraw as shown. Send E2 command. Send A1 command. Both get green messages.

    Try to draw anything, X-Y works, servo immediately slams into the end stop and gets stuck.

    Test servo with servo-tester, servo works fine.

    Also try even less than shown. One pixel for both default and weak laser power. No difference.

    And, really, even if it worked (which it doesn't) should I have to go through all this EVERY time? The software should do this for me.

  • Developer of T2Laser Software

    Have you changed the max laser power to 30-50 range?

    If it's still at 255 it's going to crash.

  • @Zax If you're asking me, I use EleksCAM, not T2Laser. Also, I've set the slider as low as zero + 1 pixel, with no difference.

  • ElekMaker Develop Department


    EleksCAM will upgrade in few days , including add SVG carving and servo num input function~

  • @EleksMaker-Z I have the new software. I found the location to choose the machine (EleksDraw) and how to set the servo mode. I set both of those. I also went in and did Rst ROM (which I assume means reset the rom) I did that too and it completed successfully.

    I even turned down the laser power to 35 just in case that still mattered.


    Servo immediately hits the upper limit and just makes ratcheting noise. It then has to be pushed back down manually since it gets stuck up there.

    Also noticed that single stepping X+ and X- move diagonally, and Y+ and Y- just "shudder". I tried the "reverse X" and "reverse Y" options (all four configurations) and it makes no difference. I have the servo and steppers plugged in as shown on the picture on this site.

    There's another thread that says that it needs different firmware, but didn't say where that firmware was or how to install it.

    Also, you have "Pulse" spelled incorrectly in the new software ("Pluse").

    This is getting pretty frustrating. And it looks like I'm not the only person having these problems.

  • @sstouk Thanks! Tried 10% and every other % without any luck.

  • Active Member

  • @nottingham82 Nope! Tried that and it didn't help.

  • ElekMaker Develop Department

    Maybe.....that servo is broken.......

  • @EleksMaker-Z - Tried a 2nd servo and has the same problem. I'm guessing there is something wrong with the software/firmware.

  • @EleksMaker-Z Nope. Not for me either. I have a servo tester. It's fine. You've got two people in this thread experiencing exactly the same problem. Also, I haven't received a reply concerning my questions above.

  • @Fracture now work your servo?

  • While I realize you may have already found the problem. I would like to say that if you will remove the gear then place the screw on the flat side of the shaft for the servo it will work. As of now I don't know if you have already found that out yet so best of luck. The noise is from the gear rotating around the servo shaft.

  • @Fracture
    Same problem, Eleksrom run August 10, 2017, assuming its the latest version. I just got and assembled this machine last week, you would think this product should be figured out by now. The manufacturer should not sell a product that is so poorly maintained. Perhaps the controller board and the firmware are not of the same version? My servo maxes out and jams. Another motor does the same. Does anyone know what the deal is? I tried A1 and E2, nothing works. Is there something I'm missing? The software is causing the servo to crash, though the rest of the machine works as advertised. Ive tried all possible power settings on the 'default laser power. System ver is set at Mana by default.

  • Developer of T2Laser Software

    @jeff I know for T2Laser when you select EleksDraw I change the max position to 45 (I could be slightly off on the exact number but it's between 30 and 50). If you try to travel more it will hit the stop and damage the servo.

    If it's not working give the T2Laser trial a go, it also supports pen changes for different colors in the DXF and the optimizer and centerline tracing work great for this machine.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.