Firmware update broke my machine

  • Help! I used the EleksRom software to update my firmware, and now it just moves the pen around without drawing as lots of GCode goes by without doing anything. How can I revert my firmware? Did I miss a step? The descriptions are not the best English.

    Thanks for any help anyone can offer.

  • The behavior is this: It raises the pen, moves to a spot, lowers the pen, and sits there while a lot of Gcode runs by. Then it repeats this over and over til it thinks it's done. So the motors work to move to a starting location, and then to home when it's finished, but then no drawing occurs. I did the standard upgrade with EleksRom.

  • Active Member

    did you go to settings and click select machine and click on the picture of the eleksdraw?

  • Thanks for your response! Yes I did... I also tried resetting the ROM from within EleksCam, the avrdude operation finishes with no errors, but no joy.

    It's a very strange thing. Everything works perfectly with the one exception that when the pen is down, the motors don't move. They only move if the pen is up. Surely a symptom this obvious will ring a bell with someone. ;)

    All I really need is the original firmware, I can reflash it with avrdude myself.

    Let me say that I am entirely pleased with the machine as a whole. It's a clever design and I enjoyed assembling it. The creators might improve their negative feedback by making it clear that this is a kit, I've seen some people put off by the assembly process. I personally like it that way. The software is another matter, but we all know how that goes.

    Thanks again for your help!

  • I'm new to the CNC world but have a good deal of development experience in other areas, so I've been trying to learn quickly... Is it possible to do something like flash grbl directly to this device? I take it that it's an Arduino Nano or something similar.

  • Active Member

    have you tried removing the pen? it could be that the pen is causing too much resistance. If so you may need to adjust your stepper driver voltage up.

  • @nottingham82 I guess I'm not making myself clear. The motors move fine unless the servo is down. I am testing it without a pen, that would be one strong pen that could stop these motors. ;)

    No, this is obviously a firmware issue. Can the makers not provide me with the original firmware? It makes me uneasy about the ElectLaser Pro I just bought.

  • Well, some combination of flashing and reflashing new and old code seems to have fixed the problem. In experimenting though, I learned that a Nano is indeed a replacement for the controller board, and that you can load grbls onto either one, but I didn't have time to experiment with it. Anyone else who has gotten grbls to work with the ElekDraw please let me know.

  • Active Member

    i havent got a clue what you are talking about. grbl is what all eleksdraw, elekslaser, and eleksmill machines use. The nano is the only thing you can load anything on. The control board is just a way to direct that information out to the stepper drivers and servo. I think you have your terms all mixed up.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.