I bought the Mill from banggood with the 500mw laser. How do yo focus this laser module? There is no movable lens like in other lasers, my beam is about 5mm in diameter.

  • focus LensLdnz

  • Active Member

    if the lens doesnt rotate then it may have a fixed focus. Move the work materiel toward or away from the laser until the dot is .1mm in diameter. A small scissor lift table might help.

    alt text

  • I tried moving the laser up and down to see if there was a focal point but was about the same within a range of a foot or more. The lens that is down in the housing is threaded into place from the diode side, threads do not come all the way out, so a second lens would have to slide in and out. Nothing was with the module so I don't know if I'm missing a part.

  • @Ed-Mulholland
    Made a screwdriver to fit the lens and it worked. Focused out about 2 inches, all is well.

  • Active Member

    sounds like maybe you were missing a lens. Glad you got it sorted! Welcome to burn club.

  • I can not seem to turn the laser module on in G Code sender, any one know how to please?

  • Active Member

    S0 switches it off and S1 to S255 or S1 to S1000 (depends from your firmware) will switch it on accordingly with power value given after letter S.

    And probably you must use M03 and M05 commands (spindle on/off) also. So M05 S0 switches laser off and for example M03 S255 switches laser on with power of 255 (max power for one case and 1/4 power in another case).

  • @MuuSer Great, I'll give it a try tomorrow.
    BTW my firmware is the GRBL 0.9 version that came together in the instruction. I heard that there is already a 1.1 version but sure where to get it. Wish me luck to test the laser out though.
    Thanks again

  • Developer of T2Laser Software

    I don't think EleksCAM supports it. I've been using 1.1 with T2Laser since release because it has better motion control (smoother and faster) as well as cool features like real time overrides and dynamic laser power.

  • @MuuSer It actually works now. YEYYY!!!
    I can turn it on / off now. My laser module is the 500MW, may I know the max power of it? I assume that it is also 500 as it said?
    but with power at 500, it hardly burn a piece of cardboard paper. Just a small back dot.

  • Your maximum s value is most likely 1000 to give you full power. As Muuser said it depends on you firmware settings, you can check by sending $$ command and look for the $30=???

  • I download T2Laser and try out testing the laser (i.e. Adjusting the focus and such)
    Now while I'm making a sample of my names... it was runing fine till half way, the laser just gone while the code still running (i.e. Axis still run but no burn ray)
    After this, laser just gone. Anyone has this issue.
    Cant seem to get it back on... has in gone???

  • Developer of T2Laser Software

    It sounds like the laser is dead, some do fail after a short time. Since the motors are working you have 12V so that is most likely the problem.

  • @Zax thanks for assuring my pain again :(
    Just send banggood a message asking for a replacement. It should not be that bad quality.
    Hopefully they will revert soon.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.