Issue with T2Laser

  • I'm having an odd issue where prints are failing at random times. I've tried all modes with the same results. Sometimes prints will finish, but others fail and the only message I see is the single word Alert in the message box. I have two engravers and get the same random failures on both. I've also tried flashing the included firmware with the same results, and even tried different Arduino boards. Other engraving software completes the print with no failures. Can anyone provide any insight. Thanks!

  • Developer of T2Laser Software

    @dave_nh I assume you are getting "Error" in the status window, this means Grbl reported a problem when running. Other software may ignore these errors, if you want T2Laser to act the same way you can disable Fail Safe Mode and enable Simple Streaming.


    These errors are for some reason, it sounds like you have already done a reasonably good job at trying to determine the cause. It is usually a bad or poor quality cable, memory issues with the Nano (especially with the latest non-Atmel copies which appear to have temperature related issues) or your computer power saving (although T2Laser has Insomnia Mode to prevent most of those from activating).

    Note: For faster and more reliable T2Laser support it is better to e-mail me as I don't always see posts on the forums.

  • Thank you. I'll give those a try and let you know.

  • Developer of T2Laser Software

    @dave_nh I will mention, if you ignore the errors (as a lot of software seems to do, including Eleks own) you run the risk that Grbl crashes and leaves the laser on while the motors are stopped = fire risk!

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.