Firmware upload error

  • When I upload Firmware default 1.1 it shows this massage
    Do you know how I can fix this problem?

  • ElekMaker Develop Department

    .. elekscam cant support 1.1 firmware

  • Developer of T2Laser Software

    @Salah What firmware do you have loaded now? Does it report Grbl Ready and work?

    The upload failure is usually due to the cable or Nano, sometimes using a different COM port, cable or pressing the reset button before uploading will fix it. Other times it means the Nano is corrupt and using the Clear EEPROM may help or you need a replacement Nano.

    I am not happy with the latest "Nano" on the Eleks Mana, it appears to have a lot more problems since they switched to a non branded microcontroller.

  • @Zax
    Hello zax
    Speaking of nano, how can I replace it.
    Do you mean that I need to replace the Arduino nano board?

  • Developer of T2Laser Software

    @Salah The Nano is the small board where the USB connects, you can replace with any other Nano clone.


  • @Zax
    I will replace it.
    Thanks a lot.

  • @Zax
    hey zax, i just purchased your software yesterday, i installed right away grbl “e” from the menu. All worked just fine, got a message that grbl e is ready etc. i tried moving motors by using arrows and it worked well.

    Then i tried to flash grbl “f” high freq pwm because the laser i ordered is ttl/pwm. I am very new in these things so i dont know if that laser would benefit from that grbl version, but i tried it. I thought that i can reflash grbl”e” back after. Boy i was wrong. No matter what i try, i keep getting “upload error 1/1” and cant see any flash progress, just another black window with some weird letters and numbers appears with the error message right after.

    Funny thing is that i can still connect laser, it still says that grbl “f” is ready and i can use laser.

    Is there ANY way how to reflash the controller board with grbl - e if i will experience any problems with current f version? Btw clear eeprom did not worked. Got the very same upload error 1/1 message.

    Thanks in advance!

  • Developer of T2Laser Software

    A genuine Arduino Nano can be flashed hundreds of times, but the latest Chinese clones (not using an Atmel microcontroller) have memory issues and are easy to corrupt. If you have another "Nano" you can use it to re-write the boot loader which may help. Sometimes they will work after letting them cool down for a while.

    There's actually nothing wrong with using that firmware, it's the same as the default Grbl 1.1e except it was compiled with 7.8kHz PWM (instead of the standard 0.98kHz). I would just leave it "as is".

  • @Zax
    Thanks a lot for quick response. Tbh i am pissed. You buy something, it works once and then it doesnt because chinese dont give a s*it about quality.
    Was browsing amazon and i am wondering if this arduino
    Would work. If yes all i have to do is just swap the old broken one with the one linked above? Or is extra soldering required?

    The thing is i really wanna solve this issue because i get “connected and grbl ready” message now. But one day.... and i am screwed

    P.s. i have to correct one thing. It was “grbl-f xy home sv” what i tried to flash over grbl-e. And it failed. Well failed - it says grbl-f is ready so... but i couldnt reflash it again with “grbl-f pwm” or anything else.

  • @Zax
    zax please can you tell me if this is nano with genuine atmel or just cheap chinese knockoff?
    i know i see the logo but you never know.

    i tried to change usb cable - didnt work
    i tried to use arduino ide software - didnt work
    i tried another computer - didnt work
    i tried to use xloader - didnt work

    honestly if this is genuine atmel i have no idea what is going on then. i just cant upload any grbl no matter what. btw when connected, that red light doesnt blink at all. it is fully on. is it good thing or bad?

    in arduino ide i get this error
    avrdude: stk500_disable() : protocol error, expect =0x14, resp = 0x95

    any idea?

    thanks in advance!

    what way can i reset nano please?

  • @Zax He could use a Duinotech NANO board -ARDUINO COMPATIBLE. The chipset used is a ATMega328P & FT232RL. Can be purchase from catelogue number XC4414, but the price is not so cheap it around $21 US for one.

  • @LogansRun basically i just have to swap mine broken one with the new nano(compatible) one? Nothing else?
    No extra soldering etc?

  • Developer of T2Laser Software

    @redcore Almost all of them are clones, unless you purchase direct from Arduino.

    The genuine Arduino Nano uses an ATMega328p microcontroller and FT232 UART, the clones often replace the FT232 with a CH340 (Chinese UART) but I don't have a problem with that as they seem stable.

    The latest Eleks Nano is using a Chinese clone microcontroller and they seem to have a lot of problems with memory and overheating.

    So that said, all Nano's are pin compatible and can be used interchangeably, plug and play. Just make sure you get one with soldered pins AND a boot loader unless you know how to install it yourself (it's pretty simple).

  • @Zax
    Would this one work for me?

    They say its with bootloader and its soldered.

  • Developer of T2Laser Software

    @redcore I don't see why not.

  • hello just had the same problem. i m running a eleksmaker a3 pro with atmel 328p . i was burning stuff for work when i decided to move back from 1f pwm to 1f laser axe.
    in the mean time i restarted my computer and t2 laser did an upgrade.
    i flashed the rom and then at the end i had this error message . since i can only make the laser go in one streight line what ever i do and whatever the rom i try to flash or even if i try to errase the rom i get error message firmware upload error.

  • Developer of T2Laser Software

    @znourf Why would you load LaserAxe firmware if you have an EleksMaker board? If you corrupted the Nano then you need to use Arduino IDE to reset the boot loader.

  • Simply because the laser axe allowed me to modify speed and laser power real time . Anyway , just found out that a spider had made it's "nest" on the nano clone :/
    So the bootloader must have a problem.
    Now i've got a uno and wanted to charge the nano clone but there is no ICSP on the clone.
    Anyone has an idea of the pining i should use to upload the bootloader to this "clone"

  • Developer of T2Laser Software

    @znourf You can load it directly from Arduino IDE, no need for ICSP or programmer.

    My default Grbl 1.1e or any of my Grbl 1.1 builds will allow real time overrides, the laseraxe firmware drives different pins for the axis so only works on their v2 boards (the latest v3 works with standard Grbl pins).

  • @Zax
    i tried that and got this with a clear eeprom command
    avrdude: verification error, first mismatch at byte 0x0002
    0x9c != 0x5c
    avrdude: verification error; content mismatch
    avrdude: verification error; content mismatch

  • Developer of T2Laser Software

    @znourf I know this is for an Uno but exact same procedure with Nano.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.