Firmware upload error

  • Developer of T2Laser Software


    It sounds like your Nano clone has become "bricked" so won't accept any more flash updates. It may be possible to fix it with an AVR programmer or another Arduino device but not via USB.

    The switch changes where the Nano gets it's power, either from USB (default) or board. Don't change it.

  • I had a similar problem when going from 1.e to a particular version of 1.1f (not all). I had to reload the boot loader using the Arduino IDE. It wasn't particularly difficult if you have the IDE and a basic understanding. If not, it may quicker to simply buy another Nano that comes with a installed bootloader as most do. They are not expensive.

  • @Zax

    I also have to add I had the exact same problem as described above after flashing to the 1,1f.
    Now I get error 1/1 when I try to flash back to 1.1e or any other firmware for that matter.
    The laser can connect to both laserweb and t2laser but is either on or of all the time and only one axis works and then only in one direction.

    On the other hand i do not even have even a rudimentary understanding of grbl or any other related software, but have managed to use my laser with other firmwares until i tried 1.1f firmware.

    Now I have just placed an order on ebay of a new arduino nano clone with bootloader and FT232 chipset.
    I hope It will work, but shipping from China to Norway takes forever.

    In the meantime I hope I will be able to cool down the current arduino to try reflash it back to 1.1e.
    I will try the tips mentioned above from Zax. Thank you for support.

    But my main point here, I guess, is that it seems like a quite significant coincidence that several others here had this problem after flashing to 1.1f in particular. Perhaps the 1.1f should be implemented with a few warnings aimed at those with eleksmaker, which presumably use the bundled fake arduino (at least when getting to know T2laser software) so they won't corrupt it. If that actually is the case though. I don't know.

    Edit: I've now ordered an original arduino nano with presoldered pins through my local electronics shop as well. I assume thats both quicker and safer.

  • Developer of T2Laser Software

    @fredevik If you install firmware not designed for your controller it could brick it. It's not a problem with 1.1f, it's a user error.

    T2Laser makes it very clear you should be using 1.1e DEFAULT unless you know what you are doing. One example I know will do this is using LaserAxe firmware so that's probably what you did.


  • @Zax Yes. You are right. I was not cautious and I believe it was the axe version i wrote onto it. Well. My lesson is learned for this time.

    However I still think its fairly easily accessible (for a bit of an incautious idiot) to have it in a drop down menu and not in a separate window. My general software intuition is just that its more serious the deeper i have to go into menus and windows. Consider it if you want.

    More than that I am really impressed with your software of course.

    By the way, do you know if there is a way to unbrick the arduino?
    Ive tried to clear it and rewrite hex through Xloader and Arduino IDE but without luck so far. I still have much to learn of this.

    Ps: I also tried to change the driver if it to some type of usb-type with Windows Device Manager, and back again to CH340 (I think it was).

  • Developer of T2Laser Software

    @fredevik You need to reload the boot loader, very simple with Arduino IDE and an AVR programmer or another Arduino device. Search for "arduino load bootloader" and you can find plenty of tutorials.

  • @Zax i have the same problem my friend they buy now the same machine and same problem what can i do ?

  • @christos93 if you check zax's answer just before your message, voilà, the answer 😉

  • Developer of T2Laser Software

    @christos93 Please describe your problem or start another thread, it's not clear to me which board you have and what you have done.

  • eleks maker a3 pro 5500mw
    last month i used 1,1e and now i have 1,1f i triy to upload firmware 1,1e and they write me this error

  • Developer of T2Laser Software

    @christos93 Where did you get 1.1f? It probably doesn't have the boot loader so you would need to reload it.

  • @Zax how can i reload?

  • Developer of T2Laser Software

    @christos93 Search for "bootloader arduino nano" or similar, you will need Arduino IDE and an AVR programmer (another Arduino clone device will work too). Alternatively get yourself a few spare Nano clones.

  • @Zax but now i buy this machin

  • Developer of T2Laser Software

    @christos93 I'm not sure what you are asking. It sounds like you loaded incompatible firmware and "bricked" the Nano, so the solution is to reset it using Arduino IDE software or just replace it. They are $2~3 each so no big expense to have spares.

  • @Zax can you send me link where i can buy this ?

  • Developer of T2Laser Software

    @christos93 Arduino IDE is free software. If you want to get a replacement Nano just search a site like banggood, ebay or aliexpress etc. You can also get on Amazon but usually more expensive but much faster.

  • @Zax aaa sorry first i triy adruino IDE how can i download this software?

  • Developer of T2Laser Software

    @christos93 When you ask questions like this I get worried that you have a laser :).

  • @Zax 😆

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.