Firmware upload error

  • Developer of T2Laser Software

    @znourf I know this is for an Uno but exact same procedure with Nano.

  • okay so i managed to save the arduino clone and even bought 2 others just in case. And today it's back to square one but all 3 are corrupt.
    So what happened? I was trying to launch a vector when the engraver set off and immediately stoped with the laser on at full power. I stoped the laser by turning it to low power mode with the switch then moved out to turn everything off.
    I turned the mana back on and nothingw as responding . I sent out to try an other nano clone but the same happened . Finally after trying to get it to work i tried a new mana board with a new nano clone. I didn't even have time for it to launch the laser stayed on. But this time the nano has the red light on al the time and gets hot.
    any ideas?

  • Developer of T2Laser Software

    @znourf Sorry, I have no idea what is going on with your machine. I have dozens of Nano's for different projects and never had any go crazy like you are saying. They are very reliable and I've found them extremely difficult to kill, even with poor ESD handling they don't seem to fail.

  • Hi @Zax , i got the same Problem ( Installed Grbl 1.1f instead of using 1.1e which runs fine) Dont know if its the LaserAxe or another.
    Now when i want to Update the Firmware to 1.1e or if i want to clear EEPROM i got the Firmware upload error (1/1). The Update from 0.9 to 1.1e DEFAULT was quite easy with T2Laser with no problems.
    But now i messed up with 1.1f and cant get back to 1.1e.

    I tried to get GRBL 1.1e with Arduino IDE ( but got errors to (below)

    Also i tried to clear the EEPROM with Adruino IDE (File -> Examples -> EEPROM -> eeprom_clear)
    On clear the eeprom and on upload GRBL i got this error: avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x0d
    On T2Laser i got avrdude: verification error, first mismatch at byte 0x002 0x9c != 0x4c
    verification error: content missmatch at the end of both command prompts

    Is my way to reset the EEPROM correct?
    If it is, i think the board is faulty.
    Can i get any Arduino Nano an replace it on the Mana SE board and Upload the Firmware (GRBL 1.1e) with T2Laser?
    Or do i need to upload some kind of boot loader?

    Thanks a lot!

    p.s. does anyone know whats this "on" switch is for under the controller?

  • Developer of T2Laser Software


    It sounds like your Nano clone has become "bricked" so won't accept any more flash updates. It may be possible to fix it with an AVR programmer or another Arduino device but not via USB.

    The switch changes where the Nano gets it's power, either from USB (default) or board. Don't change it.

  • I had a similar problem when going from 1.e to a particular version of 1.1f (not all). I had to reload the boot loader using the Arduino IDE. It wasn't particularly difficult if you have the IDE and a basic understanding. If not, it may quicker to simply buy another Nano that comes with a installed bootloader as most do. They are not expensive.

  • @Zax

    I also have to add I had the exact same problem as described above after flashing to the 1,1f.
    Now I get error 1/1 when I try to flash back to 1.1e or any other firmware for that matter.
    The laser can connect to both laserweb and t2laser but is either on or of all the time and only one axis works and then only in one direction.

    On the other hand i do not even have even a rudimentary understanding of grbl or any other related software, but have managed to use my laser with other firmwares until i tried 1.1f firmware.

    Now I have just placed an order on ebay of a new arduino nano clone with bootloader and FT232 chipset.
    I hope It will work, but shipping from China to Norway takes forever.

    In the meantime I hope I will be able to cool down the current arduino to try reflash it back to 1.1e.
    I will try the tips mentioned above from Zax. Thank you for support.

    But my main point here, I guess, is that it seems like a quite significant coincidence that several others here had this problem after flashing to 1.1f in particular. Perhaps the 1.1f should be implemented with a few warnings aimed at those with eleksmaker, which presumably use the bundled fake arduino (at least when getting to know T2laser software) so they won't corrupt it. If that actually is the case though. I don't know.

    Edit: I've now ordered an original arduino nano with presoldered pins through my local electronics shop as well. I assume thats both quicker and safer.

  • Developer of T2Laser Software

    @fredevik If you install firmware not designed for your controller it could brick it. It's not a problem with 1.1f, it's a user error.

    T2Laser makes it very clear you should be using 1.1e DEFAULT unless you know what you are doing. One example I know will do this is using LaserAxe firmware so that's probably what you did.


  • @Zax Yes. You are right. I was not cautious and I believe it was the axe version i wrote onto it. Well. My lesson is learned for this time.

    However I still think its fairly easily accessible (for a bit of an incautious idiot) to have it in a drop down menu and not in a separate window. My general software intuition is just that its more serious the deeper i have to go into menus and windows. Consider it if you want.

    More than that I am really impressed with your software of course.

    By the way, do you know if there is a way to unbrick the arduino?
    Ive tried to clear it and rewrite hex through Xloader and Arduino IDE but without luck so far. I still have much to learn of this.

    Ps: I also tried to change the driver if it to some type of usb-type with Windows Device Manager, and back again to CH340 (I think it was).

  • Developer of T2Laser Software

    @fredevik You need to reload the boot loader, very simple with Arduino IDE and an AVR programmer or another Arduino device. Search for "arduino load bootloader" and you can find plenty of tutorials.

  • @Zax i have the same problem my friend they buy now the same machine and same problem what can i do ?

  • @christos93 if you check zax's answer just before your message, voilà, the answer 😉

  • Developer of T2Laser Software

    @christos93 Please describe your problem or start another thread, it's not clear to me which board you have and what you have done.

  • eleks maker a3 pro 5500mw
    last month i used 1,1e and now i have 1,1f i triy to upload firmware 1,1e and they write me this error

  • Developer of T2Laser Software

    @christos93 Where did you get 1.1f? It probably doesn't have the boot loader so you would need to reload it.

  • @Zax how can i reload?

  • Developer of T2Laser Software

    @christos93 Search for "bootloader arduino nano" or similar, you will need Arduino IDE and an AVR programmer (another Arduino clone device will work too). Alternatively get yourself a few spare Nano clones.

  • @Zax but now i buy this machin

  • Developer of T2Laser Software

    @christos93 I'm not sure what you are asking. It sounds like you loaded incompatible firmware and "bricked" the Nano, so the solution is to reset it using Arduino IDE software or just replace it. They are $2~3 each so no big expense to have spares.

  • @Zax can you send me link where i can buy this ?

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.