T2laser Does not move servo why

  • it moves axes like its a laser but the pen does not move up and down. why?

  • Developer of T2Laser Software

    @lll You must use the Eleks Mana firmware and select the correct configuration for your machine. The servo them operates using the laser signal, but make sure laser max is 55 or lower as that's maximum travel. If you select the EleksDraw from my menu it does this automatically.

  • @Zax still not work. i upload eleksmana firmware and sellect eleksdraw E2 and servo A1 before i try and draw, and still same thing happen. do i need to plug servo into laser or the servo socket?

  • Developer of T2Laser Software

    @lll The servo may be bad, the one supplied is extremely cheap. It should be plugged in the servo header, perhaps you have it reversed?

  • @Zax are you sure i am sending E2 and A1 correctly because when i click on them before i start drawing it does not seem to do anything. What servo should i replace it with? Do they sell on amazon or ebay?

  • Developer of T2Laser Software

    Those setup commands only need to be done once, they are stored in the Nano EEPROM

    As I said you must be using the Mana firmware, it will respond as Grbl 0.9j (I think, something like that anyway) and then you click the configuration for EleksDraw and that's it.

    If you then use the manual laser power, set it to 35 and turn the "laser" on, this should drop the servo. If it doesn't, you have a problem, either wiring or the servo is dead - usually it's just stripped the gears and you can hear it doing something but no movement.

    Yes, they are available at any hobby store or Amazon. I think the standard is an SG90 but I would replace it with a metal gear unit with a slightly higher holding torque (although it doesn't need to be too powerful). They're cheap.

  • @Zax I tries different servos and still nothing happens. so it is either the mana sc board itself or software issue

  • Developer of T2Laser Software

    @lll The Mana board doesn't do much, it's just routing the Nano signals to the connector. If you have the firmware loaded and configured, T2Laser is sending a G-code command to the Nano where Grbl interprets this and moves the servo.

    To confirm, when you connect you are seeing the Connected ComX and most importantly the Grbl 0.9i Ready message and then you set the manual laser power to 35 and click laser on but nothing happens?

  • Servo it working now it was just that i bought a pack of 5 and only 2 worked out of that many so i assumed it was something els. But now when servo draws it moves pen up when it should be drawing the image and pen down when the pen should be up and moving to next position. Its like it is in reverse. why is it doing this? The servo arm is not perfectly straight when pen holder is resting on it does that matter?

  • @Zax Thanks for help its working now

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.