Troubleshooting help?

  • Hello i just finished putting together my clock, got the software and plugged it in, connected to it and then, nothing. i get a red LED on the mainboard which leads me to believe that it should be working but nothing on the clock, i have the wires daisy chained like in the video...i feel like im just missing something obvious, i tried clicking the power buttons and stuff still nothing, any help would be great i was looking forward to this...

  • I just finished putting mine together based on watching the online video. When I plugged it in, two of the lights worked and four did not light up at all. After checking all cables, I started taking it apart and discovered that I had installed four of the plastic square pieces, at the bottom of each light assemble, incorrectly which was blocking the light from reaching the numbers etched in the clear plastic squares. I am referring to the black plastic squares which have the small rectangular holes in them. They can be installed an incorrect orientation. Just flip each one over to change the small rectangular holes so each hole in the plastic square is directly over a led. You will understand better when you take apart the assemble with the etched numbers in it, and examine the plastic square that is in an incorrect orientation. Good luck. I have not yet figured out how to change the time.

  • Did you get any help? I have the same problem but can't get any help.

  • @bakecrusader
    Did you get any help, I have the same problem.

  • You probably have installed the LED boards in the wrong orientation. Plug the controller board into the open connector at the other end and see if that works.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.