Couple of issues with T2

  • Well the laser is up and running, no real issues with that. Installed the EleksCam s/w to start with, no real issues with that either so went ahead and installed T2 1.5m from Zax's server. No issues other than needed to be online. Maybe a better error message Zax? I looked at the log file though and it was pretty obvious what it was complaining about!
    Uploaded 1.1e grbl

    Just a couple of things:
    When ever I go in or out of Laser control the laser comes on in full burn mode. That's a bit annoying if the work piece is in place.

    The stop button (red hand icon) doesn't work correctly. Clicking it once does nothing, twice seems to work, but hangs s/w same as esc key. Esc key works first time and the laser stops. However the s/w seems to hang. The exit "X" top right and the other window controls (min/max) have gone and there is no way to stop the software except cntrl, alt, del.

    Is there also supposed to be a way of restarting the burn where it left off after a stop (pause)? |say to adjust the air blow?

    Dell, windows 8, convertible laptop, 32 bit
    T2 version 1.5m (TRIAL)

    I haven't changed any jumper settings on the control board from as it arrived - should I?

    Any thoughts?

    Thanks very much


  • Developer of T2Laser Software

    @DavidF T2Laser is installed from my secure server, so you would have to be online (any prerequisites like .net will also be automatically installed from Microsoft's server).

    The pulse at start up has nothing to do with the software or firmware, it's a documented design flaw with the laser driver. There should be a pull down resistor on the TTL input. You can search here to find the full explanation but I highly recommend you do the "fix" as without it the laser will go on full power if the USB disconnects (such as the computer going to sleep or the COM driver crashing).

    When you click the emergency stop button the laser will go into an alarm state, you should see the lock icon replace the home icon in the center of the jog panel. To clear the alarm you have to click that padlock, all positions are lost when using the emergency stop. Right clicking the red button will instantly stop and force disconnect the laser. None of these actions should cause a lock-up or lose the form controls, so it sounds like something is wrong. Did you get to the limit of the trial, it still shouldn't lock up but it will try to close the program. You may want to uninstall and reinstall, e-mail me if you have any questions on this procedure.

    To pause the burn, you click the envelope and it will stop after the buffer is complete. You click it again and it will ask if you want to restart. This isn't recommended as depending where in the file it stops you may get a minor defect in the job.

    There are no jumpers to change on the newer control boards.

  • Hi Zax, yep, no problem with the install on line, just that the cause of the error, or at least how to correct it wasn't immediately obvious, not a big deal really.
    Understand the big emergency stop button being a major stop, but didn't associate the smaller red hand icon with the same thing. I assumed that this might be the temp pause. For the hang, I'll try and do a screen grab and let you know.

    Attached screen shot.0_1533555027471_stop icon.PNG

    I guess a 1k to gnd for the pull down?
    One other thing, and it's probably my not reading something! What is this icon supposed to do? doesn't seem to do anything when clicked although the tip text says frame engrave??

    0_1533555843999_unknown icon.PNG

    And just an FYI really, having installed the EleksCam s/w first, it seems T2 kept the max laser value at 1000 instead of 255. In the Laser power window I changed the max value to 255 and it has been fine since then.

    Other than that, all good and I'll definitely be purchasing T2.

    Thanks again for your help.



  • Developer of T2Laser Software


    The red hand is the stop command, but if you are using the default buffering mode it won't be immediate. You have to wait for the laser to complete both the motion planner (buffer) and the command buffer before it will tell T2Laser it is "ready" and then you will get control back. The emergency stop doesn't wait, it forces all motion to immediately stop and that results in a "locked" system as the coordinates are lost. Pressing the send envelope while running puts it in a pause mode and allows you to continue.

    Yes. A 1k ohm has worked well for me on several systems, some will argue it's too low and a 2.2k or even 4.7k is better. In my testing they do help but the laser still flashes just at a low power so probably not enough to damage the material.

    That's the laser off icon, you'll find all the controls listed in the manual. The right click option is the trace frame (with laser off).

    T2Laser doesn't change your machine settings or firmware without you expressly requesting it, so you should install my firmware (Grbl 1.1e) which uses max power 255. Using other software may result in this being changed so you would need to reset or reload the Grbl parameters back to the defaults (or you can change laser max to 1000).

  • Ah, it was the right click option I was missing on that icon.
    The 1000 for the laser setting was in the setting after loading 1.1e, but as I said, it was after initially running the default firmware and Elekscam. I'll load your defaults anyway just to make sure nothing else is amiss.

    Thanks as always


  • Hi Zaxs, Just an update on the above issues. I reset to defaults and the 255 was in the laser power field and on the manual override field on the laser control screen. I then was going through all the other settings and under settings on the laser control screen Under "configure eleksmana" I selected "Eleklaser" after that the manual laser override setting changed to 1000. Sorry, didn't check if the laser power setting on the main screen also changed at the same time. I can check that tonight. Do I need to configure elelsmana??

    I tried the "Stop" command again and as before, the laser stopped moving after a second or so, but the laser stayed on and the Window controls were missing. Cntrl/alt delete was the only way to exit the s/w.

    On a positive note....
    Clicking the envelope paused the engraving perfectly, thanks for the tip!

    Also, Thanks so much for the rapid response getting my purchase license code to me last night!



  • Developer of T2Laser Software

    @DavidF You must be using my firmware (Grbl 1.1) for many of the advanced features to work, the EleksMana firmware is an obsolete version.

    The only reason you would use that old firmware is if you need to use EleksCAM, but then you forego the newer features. I'm not sure if this is somehow linked with the stop button issues, perhaps they have a bug in their modified firmware.

  • Hi Zaxs, I did load 1.1e at the beginning. I didn't realise that "Configure eleksmana" over wrote the firmware, it certainly wasn't intentional. I assumed it might be for table size, laser type or motor types etc. So the answer is to reset everything to default, reinstall 1.1e and DON'T select that option:-)



Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.