DXF Scaling Inkscape to T2

  • I am having issues with getting my inkscape dxf to have the correct scaling when imported into t2. I followed the guide posted by Zax in reply to a similar issue. My canvas is set to 150x100mm. The display units are set to mm, the size units are mm, and the scaling is set to 1.0. I save the file as a dxf, units are set to px. When i import into t2, the scaling is way off at 105.9x272.9, yet the text in the dxf looks proportional to the original

  • Developer of T2Laser Software

  • I had a similar problem and found that I had to set all the inkscape units, including in the save as dialog, to mm. Then it all came in to T2 perfectly. I was editing an existing dxf from a cad system in inkscape and that may have been why the px setting didn't work, but maybe worth a try.



  • yup Zax, i was following that pdf to the letter (at least i think i was), i tried 3 different files, and each time carefully checking that all the units and settings matched the screen shots you gave. As a last ditch attempt before i went to bed i used mm instead of px and the scaling looked at least much closer if not bang on. Not sure where i went wrong, but it was late, i will review my setting later and report back.

  • Developer of T2Laser Software

    @reflector36 It's possible they fixed the bug in Inkscape that required my workaround using px instead of mm for the export. I will download the latest version and check.

  • @Zax maybe, cause it worked very well for me to use mm as the export unit, thanks for the help

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.