T2laser & CNC milling

  • Hi @Zax, are there any instructions on how to use T2 when milling? I'm a complete newbie when it comes to milling. Followed the pdf you have on dropbox (T2Laser_CNC2.pdf) to get everything set up, but I can't seem to get the spindle motor to turn on when I attempt to cut. (motor does work, just not via the software)

    Thanks in advance

  • Developer of T2Laser Software

    @Ayesha How is the motor connected? It may be a firmware issue rather than software.

  • @Zax It's connected to a Mana 3 axis controller board and the firmware is the default 1.1e

  • Developer of T2Laser Software

    @Ayesha OK, well that's easy then. If the firmware settings haven't been changed you should be able to set manual power to 255 (max) and click the laser on icon. That would switch on the motor output, if it doesn't work then there's a hardware issue.

  • Thanks @Zak. Tried that, motor didn't turn on. Just makes a buzzing sound.

    I've just tried using Easel to test my setup and everything is working there. Motor turns on on command so I don't think there is an issue with the hardware.

    Are there any other settings in T2 I should be aware of? I just ticked "CNC Mode (Z-Axis)" under settings

  • Developer of T2Laser Software

    @Ayesha Did you try 1000 for the "power"? If you've used other software it's probably changed your firmware / parameters away from my defaults.

  • Hi @Zax, I tried 1000 power - still didn't turn on.

    Tried re-uploading 1.1e firmware & tested again at 255 & 1000 still nothing. Only difference between 255 & 1000 is the buzzing sound is louder.

    I also tried restoring defaults in T2 - again no change.

    Any other ideas as to how I can get it working?


  • Developer of T2Laser Software

    @Ayesha That doesn't make sense, software sends a G-code on command. The firmware then outputs a signal that causes the MOSFET to turn on providing current to the motor. If you can control it from one software with the same setup it will also work with T2Laser.

    I am not familiar with Easel, does it show you the G-code it's sending?

  • @Zak Easel is an online software created by Inventables. You can check it out here http://easel.inventables.com

    You're right about it not making sense, so I tried resetting everything again and managed to get it working! Something must have gotten changed in the defaults as you mentioned. Not sure why it didn't work the first time I did the reset.

    Thanks for your help in problem solving this!

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.