T2Laser Software - Introduction

  • @Zax thank u zax, ill see how i get on with it, ive just got the a3 pro and benbox wont control the pwm so using laser grbl, , it t2laser worth the money, ive done a couple of sample stuff, i have no idea how to start jumping pins and stuff

  • Developer of T2Laser Software

    @bandanabandit T2Laser has a lot more functionality, I can't comment vs other software. Like anything, you get what you pay for.

  • @Zax had a play with t2l and it's pretty dam good what I can see on the trial. I will purchase it Wednesday when I get paid 👌👊

  • Hello Zax!
    I'm already using the full version of T2 (thanks for it, very good program) I'm just moving slowly because of the language.
    Now I'm a little bit jammed, I would like to ask if I can write text in sketch mode in several queues, or just one by one, so that the laser is out of the way.
    It may be that only text written in another program can be converted into multiple sketch fomata.

    My other question if I went to gcode (save gcode, save machine gcode) (ncfile) does not accept (load gcode)

    I look forward to helping you

  • Developer of T2Laser Software

    @zoli Yes you can enter multiple lines, there are 2 ways. You can use the pipe symbol "|" to separate lines or you can use the parametric input screen (type the first line, select it and then press P) and enter it normally like a text editor.

    You can save G-code (this is the T2Laser native format) and load it later, either double click on the G-code window or use the Load G-code menu. The Machine G-code is post processed, this is for sending with other software and not for reloading in T2Laser although you could. All G-code is text, you can change the extension if needed when you save.

  • Köszönöm a választ,nagy segítség,megpróbálom.

  • Hi Zax,
    I recently installed T2 lasers and since yesterday I have a problem that I do not understand.
    The axes do not move anymore, everything else responds to the commands.
    I tried reinstalling the drivers and the software but they do not work anymore.
    Will you help me then? thank you

  • Developer of T2Laser Software

    @Usti74 Does the laser work correctly?

    Do you get the "Grbl Ready" message when connecting?

  • Hi Zax,
    Connected COM3 115200
    Grbl Ready

    "Laser Pulse" works correctly!

    Only the axes are dead. I also tried on another pc but nothing

  • Developer of T2Laser Software

    @Usti74 That's strange then, you know it has power since the laser works but none of the motors move. I'm not sure how that would happen, time to do some diagnostics work.

    Put it in debug mode and see what firmware you have loaded, hopefully my build of Grbl 1.1e.

    Try disconnecting all but one motor and see if that works, wondering if there's a short or something in the cable.

  • Hi zax I changed the PC as I have to do to activate the laser t2?

  • Developer of T2Laser Software

    @Spiderman License related issues must be handled by e-mail, please reply to your original registration e-mail if possible and let me know what help you need.

  • @Zax The servo motor doesn't work anymore. I am sure that it is because it thinks I am using a laser engraver although I use the EleksDraw but when I try to change it it just spits out errors and I cannot flash the board with more up to date software et cetera. Everything works like a charm except the servo and I tested multiple and none seem to work. Any ideas on how to solve the problem? I have a genuine Nano as my microprocessor atm.

  • Developer of T2Laser Software

    @Anima If you have an EleksDraw you can only use Eleks Mana firmware, it needs CoreXY and servo support.

  • Hi Zax,
    i'm having some beginner issues. I bought a Eleksmaker A3 pro. So fare I have installed Elekscam and found that it is not at all reliable and very limited. T2 laser seems far more useful for my purposes, but I have not been able to successfully connect it with my machine. After loading the default 1.1e Firmware, whenever I try to send the G-code to my machine, the laser flashes on for a second and then either nothing happens or it tells me that the Port is closed.

  • Developer of T2Laser Software

    @Konrad When you connect do you get the Grbl Ready message?

    If not, double check the COM port and baud rate (115200 with my default firmware).

    Once you are connected, if it disconnects this is usually a bad cable or power saving on the port.

  • T2laser worked OK last week,but now when I get to the
    control screen can't trace the frame also I cam move the
    laser with the up/down/side to side controls but the
    X and Y value stay at 0s. Thanks for any help

  • Developer of T2Laser Software

    @Bob-Huish Have you used other software? It sounds like the firmware parameters have been changed and Grbl is no longer reporting positions. If this is my firmware you can reset from the Machine menu.

  • This post is deleted!

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.