T2Laser Software - Introduction

  • @Zax
    Thanx i will try that thanx for all your help

  • Active Member

    @Zax you mean .1 right?!?! .01 would create a massive gcode and cause the machine to run over its laser width ten times per mm. This could cause memory issues as well as overburning.

  • Developer of T2Laser Software

    @nottingham82 we are talking about 2 different parameters, flatten resolution of 0.01 is acceptable (that's the smoothing of the vector) for raster conversion of text. It just means the Sketch is converted at a higher resolution and then the raster resolution of 0.1 is used for the output.

    You are correct that the output resolution should be >= 0.1 as that's the limit of the laser spot size / machine resolution.

  • Active Member

    ohhh I see what you are saying. good to know

  • Hello everyone, I just bought an elekslaser 2500 and I've been looking for the best software and the best settings for the machine, I like T2LASER, but I can only use up to 1000 g-code lines, I can try the software in addition to a few letters and squares or lines, any small drawing passes the 1000 lines, I read augures here in the forum that could use the software in trial mode up to 10 000 lines, it is not like that or it's just me ?

  • Active Member

    This post is deleted!

  • Developer of T2Laser Software

    @João-Sousa 10,000 lines of G-code for raster (images) and 1,000 lines for vector (CAD or Sketch).

    That should be sufficient to evaluate it and see that it runs your machine and gives good results.

  • Hi everyone, I bought the T2Laser, almost everything is going well.
    My problem is that I send to engrave a square of 2cm x 2cm and the machine engrave one of 1.66cm x 1.66cm for example. What I can do?

  • Developer of T2Laser Software

    @Juan-Carlos-Moreno-Argüello Did you use my firmware (Grbl 1.1e)?

  • @Zax When I try to load it, the following message appears:
    "Upload failed: Firmware was not uploaded correctly."

    My machine is "Laseraxe". But he also sends the same message
    When trying to put the 1.1f.

  • Developer of T2Laser Software

    @Juan-Carlos-Moreno-Argüello There are several version of the LaserAxe machine, the earliest one had a Nano with no bootloader so it is not possible to load firmware via USB (you must use the ICSP connector or replace the Nano). The latest machines work with default Grbl 1.1e and then there are some which need the custom firmware as they used a different pin out.

    I would see if you can install the firmware using XLoader utility, sometimes that works. Contact me via e-mail or go to benboxlaser.us for support as this forum is for EleksMaker machines.

  • @Zax I really enjoy what you have come up with and so far nothing much to complain about except for two things

    1. After the NC-program is finished the laser-commander stops responding, the status show 100% sent but essentially no buttons are responsive. The only thing working is to emergency-stop and reset.
      However, if I try to run the same program again after stopping and resetting some lines work out but then the laser just stops moving yet keeping the laser on == bad. My only solution right now is to e-stop, reset, close the controller, start the controller and go again.

    2. When the laser controller starts it turns on the laser while standing still which leads to burn-marks on the workpiece. My current solution for this is either to have the low-power button on the laser pressed, or power of the motor-driver and laser-driver when starting the laser controller.

    All this tested with the 1.1e firmware flashed from inside T2-software.

    Are these new phenomena or something that you know about?

  • Developer of T2Laser Software


    I appreciate you checking it out.

    #1 is not normal, there must be a configuration issue. I have a few settings that may resolve this. Disable DTR, select low buffer mode or enable the simple protocol. The laser should tell T2Laser when the motion is complete and then it will allow full control again, so this signal is getting lost.

    #2 this is a hardware issue, the laser should have a pull down resistor on the TTL line so when the input is "floating" (not on or off) it defaults to off. That is called fail safe and for a laser should absolutely be the default. If you pull out the USB cable, lose connection or the Nano fails the laser will go to max power which is dangerous. I can not fix this in firmware or software, but you can add a resistor between - and S to fix it (1 kohm should work).

  • @Zax Thanks for the quick reply.

    I will tend to #2 first since, as you mentioned, not safe currently.

    I will check on #1 according to your suggestion and get back here with my results.

    Once again, awesome support!

  • @Zax Alright so #2 is fixed quick and easy when you knew what to do. Kudos!

    As for #1 still not working, I tried all the different combinations with no success. I can try and film it so you can see what is going on. I will reflash and reconfigure the controller before doing the test just to have a clean slate.

    Following the link are a small collection of two movies showing what is going on. What I forgot to show is that after the first sequence is done the software end up in a spin-loop consuming 100% of one of my cpu cores.


  • Developer of T2Laser Software

    @Daniel-Wedlund The small color bar to the right of the send progress bar indicates your machine hasn't told T2Laser it is finished, also your location doesn't return to 0,0 so something isn't right.

    Is your machine a standard EleksMaker A3 or A5 with the Mana SE board and their clone Nano?

    You enabled simple streaming protocol and it didn't change? (that doesn't even use the buffer so I would not expect it to act like this)


    You may want to try a different cable or make sure the driver is correct (use the one in the Help menu). I've heard that a Windows update can load a different driver that has issues.

  • @Zax Yes, tried simple streaming before updating the driver and just tested again now with the driver installed from the help menu all with same results.
    It is the A3 with Mana SE controller got it from banggood though and judging from the looks of the Nano it seems to be a clone but looks good though...

  • Developer of T2Laser Software

    @Daniel-Wedlund I just watched your video again and I think I see the problem. You have an M30 command at the end which shouldn't be there.

    Disable that in the Design Screen, Settings / Advanced Settings menu or you can click Help / Restore Defaults.


    Also make sure you are using the Grbl post processor as that should automatically remove the non compatible commands.


  • @Zax Ahaaa, there we have it. I did have the Grbl Post processor but still M30 snuck in there... Anyway, removing the M30 from generation stage in the Advanced settings as suggested solves the problem, atleast the simple test case I had at hand... time to sleep now (Swedish time...).

    Thanks for pinpointing the issue, upvoting your post this in case it helps someone else.

  • Developer of T2Laser Software

    @Daniel-Wedlund Yeah, I just checked myself and was able to replicate the error.

    In Grbl 0.9 there was a known bug so I automatically remove the M30 but it was supposed to be fixed in Grbl 1.1 so I do not. Guess I need to rethink that!

    Thank you for bringing this to my attention. Having it enabled isn't the default but I will still fix it in the next revision.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.