T2Laser Software - Introduction

  • @Zax Thanks for the quick reply.

    I will tend to #2 first since, as you mentioned, not safe currently.

    I will check on #1 according to your suggestion and get back here with my results.

    Once again, awesome support!

  • @Zax Alright so #2 is fixed quick and easy when you knew what to do. Kudos!

    As for #1 still not working, I tried all the different combinations with no success. I can try and film it so you can see what is going on. I will reflash and reconfigure the controller before doing the test just to have a clean slate.

    Following the link are a small collection of two movies showing what is going on. What I forgot to show is that after the first sequence is done the software end up in a spin-loop consuming 100% of one of my cpu cores.


  • Developer of T2Laser Software

    @Daniel-Wedlund The small color bar to the right of the send progress bar indicates your machine hasn't told T2Laser it is finished, also your location doesn't return to 0,0 so something isn't right.

    Is your machine a standard EleksMaker A3 or A5 with the Mana SE board and their clone Nano?

    You enabled simple streaming protocol and it didn't change? (that doesn't even use the buffer so I would not expect it to act like this)


    You may want to try a different cable or make sure the driver is correct (use the one in the Help menu). I've heard that a Windows update can load a different driver that has issues.

  • @Zax Yes, tried simple streaming before updating the driver and just tested again now with the driver installed from the help menu all with same results.
    It is the A3 with Mana SE controller got it from banggood though and judging from the looks of the Nano it seems to be a clone but looks good though...

  • Developer of T2Laser Software

    @Daniel-Wedlund I just watched your video again and I think I see the problem. You have an M30 command at the end which shouldn't be there.

    Disable that in the Design Screen, Settings / Advanced Settings menu or you can click Help / Restore Defaults.


    Also make sure you are using the Grbl post processor as that should automatically remove the non compatible commands.


  • @Zax Ahaaa, there we have it. I did have the Grbl Post processor but still M30 snuck in there... Anyway, removing the M30 from generation stage in the Advanced settings as suggested solves the problem, atleast the simple test case I had at hand... time to sleep now (Swedish time...).

    Thanks for pinpointing the issue, upvoting your post this in case it helps someone else.

  • Developer of T2Laser Software

    @Daniel-Wedlund Yeah, I just checked myself and was able to replicate the error.

    In Grbl 0.9 there was a known bug so I automatically remove the M30 but it was supposed to be fixed in Grbl 1.1 so I do not. Guess I need to rethink that!

    Thank you for bringing this to my attention. Having it enabled isn't the default but I will still fix it in the next revision.

  • Zax engraver writes System.OutOfMemoryException what is it ? firmware grbl 1.1

  • Developer of T2Laser Software

    @Zverr90 It depends what you were doing to get the warning, basically you ran out of system resources (memory) which could be due to using the wrong settings and generating an excessive G-code file.

  • @Zax I agree G-code is great !!! the engraver has made 44% of the photos and stopped and wrote OutOfMemoryException !!! the resolution was 0.1 photo 35X29 cm 3500X2900 pixels !!! This problem is not solved ?

  • @Zax Sorry for my English !!!

  • Zax What settings are best for shades of grey ?

  • Developer of T2Laser Software

    It will depend on the material and what system you have, I can only suggest you experiment with the greyscale test image or provide more details.

    It is very unusual to get an out of memory error while running, is it possible you have some other software running that is causing this problem (backup, anti-virus etc). You probably don't need 0.1 resolution for such a large image, and using 0.15 and slightly defocusing the laser will make a significant speed improvement.

  • Zax do I need to configure the firmware grbl ?

  • Developer of T2Laser Software

    @Zverr90 If you are using my default firmware, Grbl 1.1e it should be configured already.

    Do you get any errors in the message box, which would indicate that Grbl has reported an error or is it just a T2Laser memory fault?

  • Zax I see the missing steps !!! how to fix ?

  • Developer of T2Laser Software

    @Zverr90 Sorry I don't understand what you mean, are you talking about a mechanical issue or still a memory error?

  • Zax У меня картинка получается полосами

  • Developer of T2Laser Software

    @Zverr90 said in T2Laser Software - Introduction:

    У меня картинка получается полосами

    Google translate doesn't help much with that... I think you are saying the image has stripes in it which would be caused by the laser being focused to a smaller beam than the resolution. Try 0.12 or de-focus the laser a little, it will blend the lines and produce a better image.

  • ok !!!

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.