T2Laser Software - Introduction

  • Developer of T2Laser Software

    @Zverr90 It depends what you were doing to get the warning, basically you ran out of system resources (memory) which could be due to using the wrong settings and generating an excessive G-code file.

  • @Zax I agree G-code is great !!! the engraver has made 44% of the photos and stopped and wrote OutOfMemoryException !!! the resolution was 0.1 photo 35X29 cm 3500X2900 pixels !!! This problem is not solved ?

  • @Zax Sorry for my English !!!

  • Zax What settings are best for shades of grey ?

  • Developer of T2Laser Software

    It will depend on the material and what system you have, I can only suggest you experiment with the greyscale test image or provide more details.

    It is very unusual to get an out of memory error while running, is it possible you have some other software running that is causing this problem (backup, anti-virus etc). You probably don't need 0.1 resolution for such a large image, and using 0.15 and slightly defocusing the laser will make a significant speed improvement.

  • Zax do I need to configure the firmware grbl ?

  • Developer of T2Laser Software

    @Zverr90 If you are using my default firmware, Grbl 1.1e it should be configured already.

    Do you get any errors in the message box, which would indicate that Grbl has reported an error or is it just a T2Laser memory fault?

  • Zax I see the missing steps !!! how to fix ?

  • Developer of T2Laser Software

    @Zverr90 Sorry I don't understand what you mean, are you talking about a mechanical issue or still a memory error?

  • Zax У меня картинка получается полосами

  • Developer of T2Laser Software

    @Zverr90 said in T2Laser Software - Introduction:

    У меня картинка получается полосами

    Google translate doesn't help much with that... I think you are saying the image has stripes in it which would be caused by the laser being focused to a smaller beam than the resolution. Try 0.12 or de-focus the laser a little, it will blend the lines and produce a better image.

  • ok !!!

  • Active Member

    This post is deleted!

  • Hello, I have an Eleksmaker A5 500mW and I'm a beginner. I have loaded the software T2Laser and I am also satisfied, but I have a problem.
    When I send the G code to the laser, the laser also starts, but it burns nothing. He runs the whole picture as if it were lasers, but in the end there is nothing. What am I doing wrong. I've been looking for the error all day. I'm desperate.
    Sorry for my wrong english, i´m from Germany :)
    Greetings Yvonne

  • Developer of T2Laser Software

    @Muckiju It sounds like the feed rate is too high, or you need more power.

    Did you load my firmware (Grbl 1.1e) or are you using the Eleks firmware?

    If you are using the Eleks you must change the laser max to 1000 using the laser icon. With my firmware max power is 255, the default value.


    To adjust the feed rate click the icon to the left, the running man and set raster feed rate to 500 and see if it burns.


  • @Zax said in T2Laser Software - Introduction:

    To adjust the feed rate click the icon to the left, the running man and set raster feed rate to 500 and see if it burns.

    The settings I have both tried again, but unfortunately it does not work. I have the software with the setting 255 for maximum laser power. I think that's the one of you.

  • Developer of T2Laser Software

    @Muckiju If you loaded my firmware, yes that's correct.

    Have you focused the laser beam to a small dot?

  • Hi again. After some time without using the laser I now have real hardware issues.
    The low-power button on the laser module does not work i.e. it runs the laser on full power making it impossible to focus correctly.
    When trying grayscale sample from t2-laser I actually manage to get a grayscale on some paper by tweaking max laser out to ca 40 out of 255 so grayscale between 0-40 worked for that piece of paper.
    Sometimes though even that I have set the laser max power for vector to 100 it will run for some time at full power and then go down to the correct power. I believe this is a hardware issue but I am now out of warranty from banggood I think... so first reaching out to all of you.
    Is this a "quick fix" on hardware, laser driver module?
    Are there any replacement to just the driver module, the laser seems to work fine.
    Next, the guy with experience: @Zax do you have any suggestion.

    Thanks everyone!

  • Active Member

    what laser do you have? there is a replacement board if you determine your ttl board is faulty.

  • @nottingham82 Looking at the images in the thread you linked to I have the exact same controller board right now SW-LD62 v2.0 and since everything else except low power mode (pressing the button gives full power) I am pretty sure it is the electronics. 0_1509818266887_20171104_175415110_iOS.jpg
    What do you say judging from this image. I should be ok going for the "third-party" spare driver.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.