XYZ tapping motors do not move...

  • Hello,

    I bought an eleksmill and try to get it started now.

    Unfortunately without success.

    The engine of the engraving pen works when I turn on the eleksmill via the button. Unfortunately, I do not get the motors from the axles working.

    I have installed candle(1.1.7), I have tried gbrl 1.1f and gbrl 1.1e firmware (with Xloader). Unfortunately without success.

    In Candle I get to see that the cnc is idle. And when I press an arrow, he thinks he is moving (green). I can hear the motor tapping but no movement. However, I have put it well together and the axles can move very smoothly if I turn it manually.

    In addition, I tried with $ = a lot of values that I encountered on forums everywhere, but this is not a success either.
    I have tried baudrate 57600 (candle do not get idle) and also 115200 (candle is idle).

    I am not very technical and I do not know what I can do now to get the Eleksmill to work.
    Someone who still has tips?

    I would be very grateful!

  • Developer of T2Laser Software

    @ElleRt If nothing works, have you check the power supply or on switch?

  • Thanks for your comment. If I connect it to mains power, and I press the on button, then the engraving pen will turn. He has power.

  • Developer of T2Laser Software

    @ElleRt OK, so if you have power to the spindle but no stepper motor activity it is probably a configuration issue. Have you tried any other software or even manual G-code commands to see if there's any movement?

  • I chose Elektcam RST ROM to restore the old firmware. Now everything works. Only I can not use Z coordinator in this program.

    For candle 1.1.7 I tried grbl 1.1 e (2 versions) and 1.1f, but then I get the X and Y and Z axes not working ..

    I really do not understand what I'm doing wrong ...

  • Developer of T2Laser Software

    @ElleRt OK, so your machine works. The problem is your software / firmware.

    T2Laser will run a CNC using any of my firmware, you can use the trial to check it all works.

  • Thanks for your comment.

    I have installed T2laser. Then the firmware default 1.1e via the program.
    Unfortunately no movement in the stepper engines.

    (I would like to work with an engraving pen instead of a laser, so I miss the Z-axis in T2laser).

  • Developer of T2Laser Software

    @ElleRt T2Laser supports Z-axis, and rotary. You can do 2.5D and 3D machining, just enable CNC mode.

    Are you sure it's not moving at all, it could be very slight? If it isn't doing anything then it sounds like a wiring or other issue. Does the coordinate display change?

    You do need to calibrate the axis in the settings menu on the laser controller screen as the mill uses 400 steps per mm and not the standard 80, you only need to click the 400 button.



Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.