Prepping Files EleksDraw using T2 Laser

  • Hi everyone,

    File prepping or V2 Laser software issue here (not sure which it is).

    Have my EleksDraw finally set up and downloaded / licensed T2 Laser because the EleksCam software was super buggy for me (using Parallels on a Mac).

    I'm having problems getting the thing to actually draw the images I'm feeding it. Heres my process, so please let me know what i'm doing wrong:

    1. Have this cool photo of a beetroot.
    2. I feed it into Adobe Illustrator, trace, and expand.
    3. I make sure all remaining lines are black.
    4. I export as a .BMP (bitmap) file (not sure if there are extra settings here im neglecting)
    5. I feed .BMP file into V2 Laser
    6. I generate G-code and go to "control laser"
    7. I ensure settings are configured for EleksDraw
    8. I hit go

    My ElkesDraw then proceeds to draw something neither beetroot-like, nor pretty. When I "preview" the g-code it becomes apparent that it's filling in all the negative space with lines. It also drags the pen from the home to the beginning of the drawing -- not ideal.

    Can someone please tell me what I'm doing wrong? I suspect a solid resource for prepping files would help me resolve this issue, though I'm struggling to find one online. I may also be neglecting a setting or two on T2 Laser.

    Perhaps @Zax has something to say about this?

    Here are some images to illustrate my demise ...

    0_1544365976227_Screenshot 2018-12-09 at 07.25.46.png

    0_1544365993529_Screenshot 2018-12-08 at 15.49.28.png

    0_1544366170492_IMAGE 2018-12-09 07:35:33.jpg

  • Developer of T2Laser Software

    @Tristan-Copley-Smith That's a crazy workflow you have there, you start with a raster and convert it to a vector, then save it back as a raster.

    Let's start at the beginning, the EleksDraw can do raster but it's really designed for vector.

    Load an image into T2Laser and use Auto-Trace to create the vector, that's it.

    That image has a lot of very small details (segments / paths) so it will do a lot of quick pen down, move, pen ups.

    It sounds like you have another issue as well. On the laser controller screen if you click laser off is the pen up? Then set the manual laser power to 50 and turn the "laser" on, does it lift up? If not, there's something wrong.

  • Thanks @Zax, i figured it out. Min power was set too high (seemingly by default) hence dragging :-/

    As you say theres a lot of "pen up, pen down" rather than the nice continuous line drawing. The beetroot image perhaps required that.

    Later I attempted to draw this text (below) on there, and was hoping it would trace along the line, but it did the same up down, up down thing. I set all strokes black and 1px thick ... I also tried tracing within V2 Laser, same thing. How can I get it to draw the continuous line?

    Since I'm obvs a bit of a newb at this, are there any file prepping resources you'd suggest?

    Basically, how does one do cool stuff like this:


    0_1544443363732_Screenshot 2018-12-10 at 04.55.34.png

  • Developer of T2Laser Software

    @Tristan-Copley-Smith If you have the default settings and use Sketch to write the text it will do exactly what you want, if you import the text as an image you would need to trace it. Right click the trace icon for auto-trace or use the menu, then it will be vector and follow the paths as you expect. You can also import DXF files, from Inkscape or a CAD program.

    I don't have specific videos for the EleksDraw but the process is the same, so if watch the videos you should get a better idea of the basics.

    Inkscape has a lot of different plug ins, you can probably create something similar and export as DXF.

    T2Laser supports using DXF colors as different pens, you can have it pause to swap pens to get multi-color drawings.

  • Thanks again @Zax -- I'll look into Inkscape as an alternative to Illustrator...

    If anyone else reading this has some kickass tutorial resources on setting up files -- specifically converting photographs into nice vector lines that can be drawn by the EleksDraw -- would love to see them!

  • Hello, I always use the function "trace image" in Illustrator. Then I have all the lines as vector graphics and can then draw them well with T2 Laser. I save the image then jpg and import it into the T2 laser software. Here is an example that I have painted.



  • Wow thats lovely @Rossi, thanks for sharing!

    When you export the image as a jpeg and import it into T2, do you just go straight into printing it, or are there any other steps you take in T2?

    Also, when its "drawing" does it draw those lines in a continuous line, or does it go up and down, plotting each segment from the top of the drawing to the bottom?


  • I am really struggling here and could use some more detailed guidance.

    My ElkesDraw will not draw images, vectors, or bitmaps in a continuous line. It continues doing up / down movements. This is despite using the trace tool in illustrator and the built in tool in V2. Can someone please provide a resource, or explain step by step, the process of generating an image that V2 will actually draw rather than "print".

    I'm getting a little frustrated here, as you can tell. Please help!

    IDEA: If someone can upload a file they know works with their ElkesDraw (drawing a continuous line) I can test it here locally and determine if this is a settings issue or my file prepping is all wrong.

  • Developer of T2Laser Software

    @Tristan-Copley-Smith I loaded the image below, clicked auto-trace and generated the G-code.


    Edit: Apparently I can't attach a G-code file so I will post as plain test, copy/paste to Notepad and save as then double click the G-code area in T2Laser and load it.

    Edit2: OK, so that didn't work either, the post was too long. Send me an e-mail and I will help you.

  • @Zax just did the same thing -- took image, fed into V2, clicked "trace", generated g-code, and the bastard is doing the old "up down, up down" ... I'll send you an email.

  • Developer of T2Laser Software

    @Tristan-Copley-Smith Are you actually tracing anything or just left clicking the trace icon?

  • OK! Yes I was just clicking the button -- I didnt realise you had to click the lines on the image to vectorise. To do the auto-vector you need to right click (as you said). Since I'm no a mac, I don't have one, but I did "control click" and nothing happened. I had to connect my bluetooth mouse which does have a right click, and now it works.

    Thanks for your help @Zax Zax!

  • Developer of T2Laser Software

    @Tristan-Copley-Smith You don't need to use the mouse shortcut, you can click Auto-Trace in the Edit menu.


    Manual trace is extremely useful in some circumstances, for example a contour cut out when you just want the outline.

  • @Tristan-Copley-Smith I then use the Auto-Trace function in T2 Laser and he then draws all connected lines in one piece. He only interrupts for new areas.

Log in to reply

Looks like your connection to Offical Forum was lost, please wait while we try to reconnect.